Mailinglist Archive: opensuse-xfce (7 mails)

< Previous Next >
[opensuse-xfce] Broken xfce login with new Xorg libraries
Hi all,

If using the latest Xorg packages from the OpenSuSE Xorg repo you will find that you cannot login in xfce (nor gnome i think).

The problem is that libxcb-aux.so.0 has been renamed (or moved to) libxcb-utils.so.0, and it is a dependency of libstartup-notification-1-0.

Despite that the latest builds of xorg-x11-libs provide a libxcb-aux.so.0 (it dissapeared but its back), my solution was to remove libxcb-aux.so.0 and to make symlink to libxcb-util.so.0 with its name. Otherwise xfce won't boot (and won't say why).

Of course, this is a solution that might break 'who knows what' in Xorg, so if anyone else has a better idea let me know. So far everything works fine for me.

--
Hector
@hecsanjuan
--
To unsubscribe, e-mail: opensuse-xfce+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-xfce+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
This Thread
  • No further messages