Mailinglist Archive: opensuse-virtual (28 mails)

< Previous Next >
Re: [opensuse-virtual] Chainloaded Leap 42.1 Xen Dom0 on EFI hardware -- network offline, xen init failing: "Failed to start The Xen xenstore"
On Wed, Nov 18, PGNet Dev wrote:

After boot, the physical interfaces exist

With their kernel names (ethN).


There's no longer any xen bridge, or properly-named eth interface, here eno1

cat /etc/sysconfig/network/ifcfg-br0
NAME='br0'
BRIDGE='yes'
BRIDGE_PORTS='eno1'

eno1 does not exist as interface name.

wicked: ifcfg-br0: unable to qualify post-up script - unknown
script type
'(null):/etc/sysconfig/network/scripts/br0-config.sh'

Not sure if these hooks are supported that way. Perhaps wicked already
has ethtool knobs.


Taking a look at console output, there a problem with xen init

At least xen works on my Leap installation. Not sure why EFI would make
any difference. Are there stale xen related .service files or sysv
scripts which prevent xenstored.service/xenstored.socked from starting?
Our xencommons.service is supposed to start everything.

Does "systemctl start xencommons.service" give any errors? Could be that
it fails because its dependencies are in failed state.

If in doubt open a bug and attach journalctl -b output. The posted
output also shows journal errors, perhaps the issue is unrelated to xen.

Olaf
--
To unsubscribe, e-mail: opensuse-virtual+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-virtual+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups