Mailinglist Archive: opensuse-virtual (33 mails)

< Previous Next >
Re: [opensuse-virtual] XEN on a 13.1 system
On 1/21/2014 at 09:20 PM, in message <52DF46FE.5080409@xxxxxxxx>, Jim Fehlig
<jfehlig@xxxxxxxx> wrote:
Charles Arnold wrote:
On 1/20/2014 at 07:29 PM, in message <52DDDBA2.5000908@xxxxxxxx>, Jim
Fehlig

<jfehlig@xxxxxxxx> wrote:

Hans Witvliet wrote:

Yes, i forgotten that xm/xend is depreceated.
Heard that a couple of times at several fosdems from Ian,
and when you mention "xm" at the xen-lists you are considered a relic
from a distant past....


How ever:
When you do a fresh instalation of the xen-stuff in 13.1, and you try to
create a VM like one is used to do in previous versions, i still got a
warning that i had to check because "xend was not running"


Charles, is there a check in {vm,virt}-install for xend running? I
vaguely recall something along those lines, but suppose it was fixed
long ago.


Yes. vm-install does check for a running xend. This is how it knows
whether to use 'xm' to start VMs or if xend is not running it uses a
libvirt connection to start VMs. The only time vm-install uses 'xl' for
starting VMs is if xend is not running and it fails to connect to libvirt.
Failure to connect could mean libvirtd was not running or some other
error occurred when connecting to libvirtd.


BTW, I don't think we should support xl in vm-install. If vm-install
cannot connect to libvirt, then it should just fail IMO. That seems to
be the behavior on KVM

Agreed. Defaulting to 'xl' on a libvirt error is wrong.
However, I wonder if there is a customer scenario where they only want
to use 'xl' but also want to use vm-install to create guests? (and even if
there is, should we support that?)

- Charles


--
To unsubscribe, e-mail: opensuse-virtual+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-virtual+owner@xxxxxxxxxxxx

< Previous Next >