Mailinglist Archive: opensuse-virtual (17 mails)

< Previous Next >
Re: [opensuse-virtual] Updating a OpenSuse 11.0 DomU to OpenSuse 11.1 problem
  • From: "Jason Douglas" <jdouglas@xxxxxxxxxx>
  • Date: Mon, 23 Mar 2009 11:27:06 -0600
  • Message-id: <49C7720A0200006F00065DE2@xxxxxxxxxxxxxxxxxxxxxxx>

On 3/23/2009 at 08:19 AM, in message <49C79A5F.7070603@xxxxxxxxx>,
Jörg
Spilker <js@xxxxxxxxx> wrote:
I recently installed OpenSuse 11.0 together with two OpenSuse 11.0
DomU´s. Now i want to update the complete system to OpenSuse 11.1. I
had
no problem´s to update the Dom0 system to OpenSuse 11.1. However
updating the DomU´s seems to be a problem.

The first install of the DomU´s was a install into directory with
whole
LVM´s partitions exported as disks.

My layout is as follows:

disk=[ 'phy:/dev/domX/daolin_root,xvda,w'
, 'phy:/dev/domX/daolin_boot,xvdb,w'
, 'phy:/dev/domX/daolin_usr,xvdc,w'
, 'phy:/dev/domX/daolin_opt,xvdd,w'
, 'phy:/dev/domX/daolin_var,xvde,w'
, 'phy:/dev/domX/daolin_src,xvdf,w'
, 'phy:/dev/domX/daolin_tmp,xvdg,w'
, 'phy:/dev/data/home,xvdh,w'
, 'phy:/dev/data/foto,xvdi,w'
, 'phy:/dev/data/imap,xvdj,w'
, 'phy:/dev/data/news,xvdk,w'
, 'phy:/dev/data/squid,xvdl,w'
, 'phy:/dev/data/srv,xvdm,w'
, 'phy:/dev/hda1,xvdn,w'
, 'phy:/dev/backup/backup,xvdo,w'
, 'phy:/dev/sr0,xvdy:cdrom,r'
, 'phy:/dev/sr1,xvdz:cdrom,r']

for the initial install i did mount the lvm volumens to subdirs of
/tmp/install and did a install into this directory.

The fstab of the system contains entry like /dev/xvda for
mountpoints
(i.e a whole disk, not a partition)

This was working fine.

But i don´t know how i know can update this system to 11.1.
Installation
into a directory seems to only can handle fresh installs.

I created a special startup file for xen with allows a disk install
of
OpenSuse 11.1.

What kind of startup file is this? Could you send it to me?

However this doesn´t work because the exported disks are
not recognized as expected. When i choose the update option, the
installer shows no partitions at all.


I haven't tried this scenario with an upgrade from os11.0 to 11.1, but
when I have seen this before, I was always able to manually select the
partition to upgrade (even though they weren't displayed on the main
update page). What happens when you try this?

I have no idea to solve this problem. Do i really have to partition
an
exported lvm volume first in the DomU before using it as a mountpoint
?

You should be able to do everything you need to from within the domU.
Other than config file modifications, you shouldn't have to do any
mounting in dom0. In fact, I have seen instances where lvm volumes were
getting auto-mounted in 11.1 dom0 which was causing endless problems for
my VMs.



Greetings, Jörg
--
To unsubscribe, e-mail: opensuse-virtual+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-virtual+help@xxxxxxxxxxxx

I will try to duplicate a similar (albeit simpler) setup and see what
problems I encounter. Good luck.

Jason
--
To unsubscribe, e-mail: opensuse-virtual+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-virtual+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References