Mailinglist Archive: opensuse-virtual (14 mails)

< Previous Next >
[opensuse-virtual] mounted img file read-only.
  • From: James Pifer <jep@xxxxxxxxxxxxxxxx>
  • Date: Fri, 18 Apr 2008 20:32:17 -0400
  • Message-id: <1208565137.20924.29.camel@xxxxxxxxxxxxxxxxxxxxxxxx>
So I've been converting Windows VMWare VM's to xen domU's using this
site as a guide:

I even took a MS VM, converted to VMWare, then to a domU and it worked.

I have one PCI Device that is not being found on all the machines I've

Q1) I assume since these are full virtualization that I need the drivers
for the specific hardware?

I also had my first failed conversion. It fails in the steps replacing
the HAL version. When I mount the img file like:
mount -o loop,offset=$((63*512)),rw server.img /mnt

I can view the file system, but when I try to put the right HAL.dll in
place I get:
cp: cannot remove `/mnt/WINNT/system32/hal.dll': Read-only file system

Q2) Any ideas why this file system is Read-only? This is the same
procedure I've done on all my conversions. First 4 of them worked fine.

Any help is appreciated.


To unsubscribe, e-mail: opensuse-virtual+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-virtual+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages