Mailinglist Archive: opensuse-updates (175 mails)

< Previous Next >
openSUSE-RU-2020:0311-1: moderate: Recommended update for mariadb-connector-c
openSUSE Recommended Update: Recommended update for mariadb-connector-c
______________________________________________________________________________

Announcement ID: openSUSE-RU-2020:0311-1
Rating: moderate
References: #1162388
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that has one recommended fix can now be installed.

Description:

This update for mariadb-connector-c fixes the following issues:

New upstream version 3.1.7 (bsc#1162388)
- TLS/SSL: when the client doesn't provide a CA file and the option
ssl_verify_server_cert was set, the peer certificate will be validated
against the system CA.
- ERROR 2026 (HY000): SSL connection error due to Certificate signature
check failed
- Provide error code and message for SChannel errors
- SEC_E_INVALID_TOKEN when server sends large message during SSL handshake

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Recommended Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-311=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

libmariadb-devel-3.1.7-lp151.3.9.1
libmariadb-devel-debuginfo-3.1.7-lp151.3.9.1
libmariadb3-3.1.7-lp151.3.9.1
libmariadb3-debuginfo-3.1.7-lp151.3.9.1
libmariadb_plugins-3.1.7-lp151.3.9.1
libmariadb_plugins-debuginfo-3.1.7-lp151.3.9.1
libmariadbprivate-3.1.7-lp151.3.9.1
libmariadbprivate-debuginfo-3.1.7-lp151.3.9.1
mariadb-connector-c-debugsource-3.1.7-lp151.3.9.1

- openSUSE Leap 15.1 (x86_64):

libmariadb3-32bit-3.1.7-lp151.3.9.1
libmariadb3-32bit-debuginfo-3.1.7-lp151.3.9.1


References:

https://bugzilla.suse.com/1162388


< Previous Next >
This Thread
  • No further messages