Mailinglist Archive: opensuse-updates (199 mails)

< Previous Next >
openSUSE-SU-2019:1639-1: important: Security update for gstreamer-plugins-base
openSUSE Security Update: Security update for gstreamer-plugins-base
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1639-1
Rating: important
References: #1133375
Cross-References: CVE-2019-9928
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for gstreamer-plugins-base fixes the following issue: Security
issue fixed:

- CVE-2019-9928: Fixed a heap-based overflow in the rtsp connection parser
(bsc#1133375).

This update was imported from the SUSE:SLE-12-SP2:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2019-1639=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

gstreamer-plugins-base-1.8.3-8.3.1
gstreamer-plugins-base-debuginfo-1.8.3-8.3.1
gstreamer-plugins-base-debugsource-1.8.3-8.3.1
gstreamer-plugins-base-devel-1.8.3-8.3.1
gstreamer-plugins-base-doc-1.8.3-8.3.1
libgstallocators-1_0-0-1.8.3-8.3.1
libgstallocators-1_0-0-debuginfo-1.8.3-8.3.1
libgstapp-1_0-0-1.8.3-8.3.1
libgstapp-1_0-0-debuginfo-1.8.3-8.3.1
libgstaudio-1_0-0-1.8.3-8.3.1
libgstaudio-1_0-0-debuginfo-1.8.3-8.3.1
libgstfft-1_0-0-1.8.3-8.3.1
libgstfft-1_0-0-debuginfo-1.8.3-8.3.1
libgstpbutils-1_0-0-1.8.3-8.3.1
libgstpbutils-1_0-0-debuginfo-1.8.3-8.3.1
libgstriff-1_0-0-1.8.3-8.3.1
libgstriff-1_0-0-debuginfo-1.8.3-8.3.1
libgstrtp-1_0-0-1.8.3-8.3.1
libgstrtp-1_0-0-debuginfo-1.8.3-8.3.1
libgstrtsp-1_0-0-1.8.3-8.3.1
libgstrtsp-1_0-0-debuginfo-1.8.3-8.3.1
libgstsdp-1_0-0-1.8.3-8.3.1
libgstsdp-1_0-0-debuginfo-1.8.3-8.3.1
libgsttag-1_0-0-1.8.3-8.3.1
libgsttag-1_0-0-debuginfo-1.8.3-8.3.1
libgstvideo-1_0-0-1.8.3-8.3.1
libgstvideo-1_0-0-debuginfo-1.8.3-8.3.1
typelib-1_0-GstAllocators-1_0-1.8.3-8.3.1
typelib-1_0-GstApp-1_0-1.8.3-8.3.1
typelib-1_0-GstAudio-1_0-1.8.3-8.3.1
typelib-1_0-GstFft-1_0-1.8.3-8.3.1
typelib-1_0-GstPbutils-1_0-1.8.3-8.3.1
typelib-1_0-GstRtp-1_0-1.8.3-8.3.1
typelib-1_0-GstRtsp-1_0-1.8.3-8.3.1
typelib-1_0-GstSdp-1_0-1.8.3-8.3.1
typelib-1_0-GstTag-1_0-1.8.3-8.3.1
typelib-1_0-GstVideo-1_0-1.8.3-8.3.1

- openSUSE Leap 42.3 (x86_64):

gstreamer-plugins-base-32bit-1.8.3-8.3.1
gstreamer-plugins-base-debuginfo-32bit-1.8.3-8.3.1
gstreamer-plugins-base-devel-32bit-1.8.3-8.3.1
libgstallocators-1_0-0-32bit-1.8.3-8.3.1
libgstallocators-1_0-0-debuginfo-32bit-1.8.3-8.3.1
libgstapp-1_0-0-32bit-1.8.3-8.3.1
libgstapp-1_0-0-debuginfo-32bit-1.8.3-8.3.1
libgstaudio-1_0-0-32bit-1.8.3-8.3.1
libgstaudio-1_0-0-debuginfo-32bit-1.8.3-8.3.1
libgstfft-1_0-0-32bit-1.8.3-8.3.1
libgstfft-1_0-0-debuginfo-32bit-1.8.3-8.3.1
libgstpbutils-1_0-0-32bit-1.8.3-8.3.1
libgstpbutils-1_0-0-debuginfo-32bit-1.8.3-8.3.1
libgstriff-1_0-0-32bit-1.8.3-8.3.1
libgstriff-1_0-0-debuginfo-32bit-1.8.3-8.3.1
libgstrtp-1_0-0-32bit-1.8.3-8.3.1
libgstrtp-1_0-0-debuginfo-32bit-1.8.3-8.3.1
libgstrtsp-1_0-0-32bit-1.8.3-8.3.1
libgstrtsp-1_0-0-debuginfo-32bit-1.8.3-8.3.1
libgstsdp-1_0-0-32bit-1.8.3-8.3.1
libgstsdp-1_0-0-debuginfo-32bit-1.8.3-8.3.1
libgsttag-1_0-0-32bit-1.8.3-8.3.1
libgsttag-1_0-0-debuginfo-32bit-1.8.3-8.3.1
libgstvideo-1_0-0-32bit-1.8.3-8.3.1
libgstvideo-1_0-0-debuginfo-32bit-1.8.3-8.3.1

- openSUSE Leap 42.3 (noarch):

gstreamer-plugins-base-lang-1.8.3-8.3.1


References:

https://www.suse.com/security/cve/CVE-2019-9928.html
https://bugzilla.suse.com/1133375


< Previous Next >
This Thread
  • No further messages