Mailinglist Archive: opensuse-updates (161 mails)

< Previous Next >
openSUSE-RU-2019:0221-1: moderate: Recommended update for itstool
openSUSE Recommended Update: Recommended update for itstool
______________________________________________________________________________

Announcement ID: openSUSE-RU-2019:0221-1
Rating: moderate
References: #1065270 #1111019
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that has two recommended fixes can now be
installed.

Description:

This update for itstool and python-libxml2-python fixes the following
issues:

Package: itstool
- Updated version to support Python3. (bnc#1111019)

Package: python-libxml2-python
- Fix segfault when parsing invalid data. (bsc#1065270)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Recommended Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-221=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

libxml2-2-2.9.7-lp150.2.6.1
libxml2-2-debuginfo-2.9.7-lp150.2.6.1
libxml2-debugsource-2.9.7-lp150.2.6.1
libxml2-devel-2.9.7-lp150.2.6.1
libxml2-tools-2.9.7-lp150.2.6.1
libxml2-tools-debuginfo-2.9.7-lp150.2.6.1
python-libxml2-python-debugsource-2.9.7-lp150.2.6.1
python2-libxml2-python-2.9.7-lp150.2.6.1
python2-libxml2-python-debuginfo-2.9.7-lp150.2.6.1
python3-libxml2-python-2.9.7-lp150.2.6.1
python3-libxml2-python-debuginfo-2.9.7-lp150.2.6.1

- openSUSE Leap 15.0 (x86_64):

libxml2-2-32bit-2.9.7-lp150.2.6.1
libxml2-2-32bit-debuginfo-2.9.7-lp150.2.6.1
libxml2-devel-32bit-2.9.7-lp150.2.6.1

- openSUSE Leap 15.0 (noarch):

itstool-2.0.5-lp150.2.3.1
libxml2-doc-2.9.7-lp150.2.6.1


References:

https://bugzilla.suse.com/1065270
https://bugzilla.suse.com/1111019


< Previous Next >
This Thread
  • No further messages