Mailinglist Archive: opensuse-updates (161 mails)

< Previous Next >
openSUSE-RU-2019:0222-1: moderate: Recommended update for post-build-checks
openSUSE Recommended Update: Recommended update for post-build-checks
______________________________________________________________________________

Announcement ID: openSUSE-RU-2019:0222-1
Rating: moderate
References: #1109470
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that has one recommended fix can now be installed.

Description:

This update for post-build-checks fixes the following issues:

* Add suse-ignored-rpaths.conf (bsc#1109470)
* 50-check-kernel-build-id:

- add archs i686 ppc ppc64 s390 armv6l armv7l
- regroup checks for image and debuginfo
- make arch list a little more robust
- Handle i586. Also improve error handling when arch not found.
- Change err() to return 0. Only return 1 if we successfully compared
the id's and there was a discrepancy.
- change file mode to 755 for 50-check-kernel-build-id to match all
other checks

* make all OBS tex pdf builds reproducible by exporting FORCE_SOURCE_DATE
as 1
* check for -fstack-clash-protection instead of -fmessage-length, as that
one will be removed from optflags
* Add kernel-build-id consistency check
* Warnings for core files, no errors yet
* QT_HASH_SEED has to be 0
* Mark test as broken due to GCC 8 and fortification.

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Recommended Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-222=1



Package List:

- openSUSE Leap 15.0 (noarch):

post-build-checks-84.88+git20181015.ceb5c96-lp150.2.3.1


References:

https://bugzilla.suse.com/1109470


< Previous Next >
This Thread
  • No further messages