Mailinglist Archive: opensuse-updates (161 mails)

< Previous Next >
openSUSE-RU-2019:0190-1: moderate: Recommended update for python-kiwi
openSUSE Recommended Update: Recommended update for python-kiwi
______________________________________________________________________________

Announcement ID: openSUSE-RU-2019:0190-1
Rating: moderate
References: #1110871 #1119792
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that has two recommended fixes can now be
installed.

Description:

This update for python-kiwi provides the following fixes:

- Rebuild auto generated code with stable generateDS. For some reason the
xml_parse code generated by generateDS v2.29.24 caused warnings on
simple type XSD patterns. Therefore the code was rebuilt with the stable
build version v2.29.14 which fixed the issue. (bsc#1119792)
- Add Codec utils for bytes literals decoding. In case of a literal
decoding failure it tries to decode the result in utf-8. This is handy
in python2 environments where python and the host might be using
different charset configurations. In python3 this issue seems to be
solved. (bsc#1110871)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Recommended Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-190=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

dracut-kiwi-lib-9.16.19-lp150.2.13.1
dracut-kiwi-live-9.16.19-lp150.2.13.1
dracut-kiwi-oem-dump-9.16.19-lp150.2.13.1
dracut-kiwi-oem-repart-9.16.19-lp150.2.13.1
dracut-kiwi-overlay-9.16.19-lp150.2.13.1
kiwi-man-pages-9.16.19-lp150.2.13.1
kiwi-pxeboot-9.16.19-lp150.2.13.1
kiwi-tools-9.16.19-lp150.2.13.1
kiwi-tools-debuginfo-9.16.19-lp150.2.13.1
python-kiwi-debugsource-9.16.19-lp150.2.13.1
python2-kiwi-9.16.19-lp150.2.13.1
python3-kiwi-9.16.19-lp150.2.13.1


References:

https://bugzilla.suse.com/1110871
https://bugzilla.suse.com/1119792


< Previous Next >
This Thread
  • No further messages