Mailinglist Archive: opensuse-updates (161 mails)

< Previous Next >
openSUSE-SU-2019:0174-1: important: Security update for curl
openSUSE Security Update: Security update for curl
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:0174-1
Rating: important
References: #1123371 #1123377 #1123378
Cross-References: CVE-2018-16890 CVE-2019-3822 CVE-2019-3823

Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

This update for curl fixes the following issues:

Security issues fixed:

- CVE-2019-3823: Fixed a heap out-of-bounds read in the code handling the
end-of-response for SMTP (bsc#1123378).
- CVE-2019-3822: Fixed a stack based buffer overflow in the function
creating an outgoing NTLM type-3 message (bsc#1123377).
- CVE-2018-16890: Fixed a heap buffer out-of-bounds read in the function
handling incoming NTLM type-2 messages (bsc#1123371).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-174=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

curl-7.60.0-lp150.2.18.1
curl-debuginfo-7.60.0-lp150.2.18.1
curl-debugsource-7.60.0-lp150.2.18.1
curl-mini-7.60.0-lp150.2.18.1
curl-mini-debuginfo-7.60.0-lp150.2.18.1
curl-mini-debugsource-7.60.0-lp150.2.18.1
libcurl-devel-7.60.0-lp150.2.18.1
libcurl-mini-devel-7.60.0-lp150.2.18.1
libcurl4-7.60.0-lp150.2.18.1
libcurl4-debuginfo-7.60.0-lp150.2.18.1
libcurl4-mini-7.60.0-lp150.2.18.1
libcurl4-mini-debuginfo-7.60.0-lp150.2.18.1

- openSUSE Leap 15.0 (x86_64):

libcurl-devel-32bit-7.60.0-lp150.2.18.1
libcurl4-32bit-7.60.0-lp150.2.18.1
libcurl4-32bit-debuginfo-7.60.0-lp150.2.18.1


References:

https://www.suse.com/security/cve/CVE-2018-16890.html
https://www.suse.com/security/cve/CVE-2019-3822.html
https://www.suse.com/security/cve/CVE-2019-3823.html
https://bugzilla.suse.com/1123371
https://bugzilla.suse.com/1123377
https://bugzilla.suse.com/1123378


< Previous Next >
This Thread
  • No further messages