Mailinglist Archive: opensuse-updates (161 mails)

< Previous Next >
openSUSE-RU-2019:0157-1: moderate: Recommended update for libtermkey, neovim, and python-neovim
openSUSE Recommended Update: Recommended update for libtermkey, neovim, and
python-neovim
______________________________________________________________________________

Announcement ID: openSUSE-RU-2019:0157-1
Rating: moderate
References: #1094627 #1098800 #1100496
Affected Products:
openSUSE Backports SLE-15
______________________________________________________________________________

An update that has three recommended fixes can now be
installed.

Description:

This update provides fixes and improvements for several packages:

Package: libtermkey

- Version bump to 0.20:
* Adds parsing of DCS and OSC control strings
* Fixed handling of Ctrl-Space, bugfix for keypad mode switching, endian
fix for unicode keys (thanks jamessan)

Package: neovim

- Puts the system-wide config now in /etc (boo#1098800)
- Several other minor changes (see rpm .changes file for more details)
- Version bump to 0.3.1 introduced several features, bug fixes, and other
changes

Package: python-neovim

- Version bump to 0.3.1 introduced several smaller changes to work with
neovim (see rpm .changes file for more details)

This update was imported from the openSUSE:Leap:15.0:Update update project.


Patch Instructions:

To install this openSUSE Recommended Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Backports SLE-15:

zypper in -t patch openSUSE-2019-157=1



Package List:

- openSUSE Backports SLE-15 (aarch64 ppc64le s390x x86_64):

libtermkey-debugsource-0.20-bp150.3.3.1
libtermkey-devel-0.20-bp150.3.3.1
libtermkey1-0.20-bp150.3.3.1
libtermkey1-debuginfo-0.20-bp150.3.3.1
lua51-bit32-5.3.0-bp150.2.1
lua51-bit32-debuginfo-5.3.0-bp150.2.1
lua51-bit32-debugsource-5.3.0-bp150.2.1

- openSUSE Backports SLE-15 (x86_64):

neovim-0.3.1-bp150.2.3.1
neovim-debuginfo-0.3.1-bp150.2.3.1
neovim-debugsource-0.3.1-bp150.2.3.1

- openSUSE Backports SLE-15 (noarch):

neovim-lang-0.3.1-bp150.2.3.1
python2-neovim-0.3.1-bp150.3.3.1
python3-neovim-0.3.1-bp150.3.3.1


References:

https://bugzilla.suse.com/1094627
https://bugzilla.suse.com/1098800
https://bugzilla.suse.com/1100496


< Previous Next >
This Thread
  • No further messages