Mailinglist Archive: opensuse-updates (82 mails)

< Previous Next >
openSUSE-SU-2018:1095-1: moderate: Security update for perl
openSUSE Security Update: Security update for perl
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1095-1
Rating: moderate
References: #1082216 #1082233 #1082234
Cross-References: CVE-2018-6797 CVE-2018-6798 CVE-2018-6913

Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

This update for perl fixes the following issues:

Security issues fixed:

- CVE-2018-6913: Fixed space calculation issues in pp_pack.c (bsc#1082216).
- CVE-2018-6798: Fixed heap buffer overflow in regexec.c (bsc#1082233).
- CVE-2018-6797: Fixed sharp-s regexp overflow (bsc#1082234).

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-400=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

perl-5.18.2-12.1
perl-base-5.18.2-12.1
perl-base-debuginfo-5.18.2-12.1
perl-debuginfo-5.18.2-12.1
perl-debugsource-5.18.2-12.1

- openSUSE Leap 42.3 (x86_64):

perl-32bit-5.18.2-12.1
perl-base-32bit-5.18.2-12.1
perl-base-debuginfo-32bit-5.18.2-12.1
perl-debuginfo-32bit-5.18.2-12.1

- openSUSE Leap 42.3 (noarch):

perl-doc-5.18.2-12.1


References:

https://www.suse.com/security/cve/CVE-2018-6797.html
https://www.suse.com/security/cve/CVE-2018-6798.html
https://www.suse.com/security/cve/CVE-2018-6913.html
https://bugzilla.suse.com/1082216
https://bugzilla.suse.com/1082233
https://bugzilla.suse.com/1082234


< Previous Next >
This Thread
  • No further messages