Mailinglist Archive: opensuse-updates (119 mails)

< Previous Next >
openSUSE-SU-2018:0765-1: moderate: Security update for postgresql96
openSUSE Security Update: Security update for postgresql96
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:0765-1
Rating: moderate
References: #1081925
Cross-References: CVE-2018-1058
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for postgresql96 fixes the following issues:

Security issues fixed:

- CVE-2018-1058: Fixed uncontrolled search path element in pg_dump and
other client applications (bsc#1081925).

Bug fixes:

- See release notes for details:
* https://www.postgresql.org/docs/9.6/static/release-9-6-8.html

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-287=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

libecpg6-9.6.8-15.1
libecpg6-debuginfo-9.6.8-15.1
libpq5-9.6.8-15.1
libpq5-debuginfo-9.6.8-15.1
postgresql96-9.6.8-15.1
postgresql96-contrib-9.6.8-15.1
postgresql96-contrib-debuginfo-9.6.8-15.1
postgresql96-debuginfo-9.6.8-15.1
postgresql96-debugsource-9.6.8-15.1
postgresql96-devel-9.6.8-15.1
postgresql96-devel-debuginfo-9.6.8-15.1
postgresql96-libs-debugsource-9.6.8-15.1
postgresql96-plperl-9.6.8-15.1
postgresql96-plperl-debuginfo-9.6.8-15.1
postgresql96-plpython-9.6.8-15.1
postgresql96-plpython-debuginfo-9.6.8-15.1
postgresql96-pltcl-9.6.8-15.1
postgresql96-pltcl-debuginfo-9.6.8-15.1
postgresql96-server-9.6.8-15.1
postgresql96-server-debuginfo-9.6.8-15.1
postgresql96-test-9.6.8-15.1

- openSUSE Leap 42.3 (x86_64):

libecpg6-32bit-9.6.8-15.1
libecpg6-debuginfo-32bit-9.6.8-15.1
libpq5-32bit-9.6.8-15.1
libpq5-debuginfo-32bit-9.6.8-15.1

- openSUSE Leap 42.3 (noarch):

postgresql96-docs-9.6.8-15.1


References:

https://www.suse.com/security/cve/CVE-2018-1058.html
https://bugzilla.suse.com/1081925


< Previous Next >
This Thread
  • No further messages