Mailinglist Archive: opensuse-updates (119 mails)

< Previous Next >
openSUSE-SU-2018:0623-1: moderate: Security update for wavpack
openSUSE Security Update: Security update for wavpack
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:0623-1
Rating: moderate
References: #1021483
Cross-References: CVE-2016-10169 CVE-2016-10170 CVE-2016-10171
CVE-2016-10172
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:

This update for wavpack fixes the following issues:

- CVE-2016-10169 CVE-2016-10170 CVE-2016-10171 CVE-2016-10172: Make sure
upper and lower boundaries make sense, to avoid out of bounds memory
reads that could lead to crashes or disclosing memory. (bsc#1021483)

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-227=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

libwavpack1-4.60.99-9.3.1
libwavpack1-debuginfo-4.60.99-9.3.1
wavpack-4.60.99-9.3.1
wavpack-debuginfo-4.60.99-9.3.1
wavpack-debugsource-4.60.99-9.3.1
wavpack-devel-4.60.99-9.3.1

- openSUSE Leap 42.3 (x86_64):

libwavpack1-32bit-4.60.99-9.3.1
libwavpack1-debuginfo-32bit-4.60.99-9.3.1


References:

https://www.suse.com/security/cve/CVE-2016-10169.html
https://www.suse.com/security/cve/CVE-2016-10170.html
https://www.suse.com/security/cve/CVE-2016-10171.html
https://www.suse.com/security/cve/CVE-2016-10172.html
https://bugzilla.suse.com/1021483


< Previous Next >
This Thread
  • No further messages