Mailinglist Archive: opensuse-updates (119 mails)

< Previous Next >
openSUSE-SU-2018:0615-1: moderate: Security update for leptonica
openSUSE Security Update: Security update for leptonica
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:0615-1
Rating: moderate
References: #1079358 #1081576 #1081631
Cross-References: CVE-2018-3836 CVE-2018-7186 CVE-2018-7247

Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

This update for leptonica fixes the following issues:

- CVE-2018-7247: Fixed a buffer overflow in in src/viewfiles.c with
unsanitized input (rootname) (boo#1081631)
- CVE-2018-7186: Fixed multiple stack-based buffer overflows in
gplotRead() and ptaReadStream() (boo#1081576)
- CVE-2018-3836: Added additional bad characters, to prevent command
injection by invoking it via $(command) (boo#1079358)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-226=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

leptonica-debugsource-1.72-9.1
leptonica-devel-1.72-9.1
leptonica-tools-1.72-9.1
leptonica-tools-debuginfo-1.72-9.1
liblept4-1.72-9.1
liblept4-debuginfo-1.72-9.1

- openSUSE Leap 42.3 (x86_64):

liblept4-32bit-1.72-9.1
liblept4-debuginfo-32bit-1.72-9.1


References:

https://www.suse.com/security/cve/CVE-2018-3836.html
https://www.suse.com/security/cve/CVE-2018-7186.html
https://www.suse.com/security/cve/CVE-2018-7247.html
https://bugzilla.suse.com/1079358
https://bugzilla.suse.com/1081576
https://bugzilla.suse.com/1081631


< Previous Next >
This Thread
  • No further messages