Mailinglist Archive: opensuse-updates (111 mails)

< Previous Next >
openSUSE-SU-2018:0496-1: moderate: Security update for GraphicsMagick
openSUSE Security Update: Security update for GraphicsMagick
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:0496-1
Rating: moderate
References: #1050617 #1050669 #1056768 #1072934
Cross-References: CVE-2017-11637 CVE-2017-11638 CVE-2017-11642
CVE-2017-14060 CVE-2017-17503
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes 5 vulnerabilities is now available.

Description:

This update for GraphicsMagick fixes the following issues:

* CVE-2017-11637: Fixed a NULL pointer dereference in WritePCLImage() in
coders/pcl.c (boo#1050669)
* CVE-2017-11638, CVE-2017-11642: Fixed a NULL pointer dereference in
theWriteMAPImage() in coders/map.c (boo#1050617)
* CVE-2017-17503: Fixed a heap-based buffer overflow in the ReadGRAYImage
(boo#1072934)
* CVE-2017-14060: Fixed a NULL Pointer Dereference issue in the
ReadCUTImage function in coders/cut.c that could cause a Denial of
Service (boo#1056768)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-191=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

GraphicsMagick-1.3.25-71.1
GraphicsMagick-debuginfo-1.3.25-71.1
GraphicsMagick-debugsource-1.3.25-71.1
GraphicsMagick-devel-1.3.25-71.1
libGraphicsMagick++-Q16-12-1.3.25-71.1
libGraphicsMagick++-Q16-12-debuginfo-1.3.25-71.1
libGraphicsMagick++-devel-1.3.25-71.1
libGraphicsMagick-Q16-3-1.3.25-71.1
libGraphicsMagick-Q16-3-debuginfo-1.3.25-71.1
libGraphicsMagick3-config-1.3.25-71.1
libGraphicsMagickWand-Q16-2-1.3.25-71.1
libGraphicsMagickWand-Q16-2-debuginfo-1.3.25-71.1
perl-GraphicsMagick-1.3.25-71.1
perl-GraphicsMagick-debuginfo-1.3.25-71.1


References:

https://www.suse.com/security/cve/CVE-2017-11637.html
https://www.suse.com/security/cve/CVE-2017-11638.html
https://www.suse.com/security/cve/CVE-2017-11642.html
https://www.suse.com/security/cve/CVE-2017-14060.html
https://www.suse.com/security/cve/CVE-2017-17503.html
https://bugzilla.suse.com/1050617
https://bugzilla.suse.com/1050669
https://bugzilla.suse.com/1056768
https://bugzilla.suse.com/1072934


< Previous Next >
This Thread
  • No further messages