Mailinglist Archive: opensuse-updates (111 mails)

< Previous Next >
openSUSE-SU-2018:0475-1: moderate: Security update for irssi
openSUSE Security Update: Security update for irssi
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:0475-1
Rating: moderate
References: #1081238
Cross-References: CVE-2018-7050 CVE-2018-7051 CVE-2018-7052
CVE-2018-7053 CVE-2018-7054
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes 5 vulnerabilities is now available.

Description:

This update for irssi fixes the following security issues:

- CVE-2018-7054: Use after free when server is disconnected during
netsplits
- CVE-2018-7053: Use after free when SASL messages are received in
unexpected order
- CVE-2018-7050: Null pointer dereference when an "empty" nick has been
observed
- CVE-2018-7052: When the number of windows exceed the available space,
Irssi would crash due to Null pointer dereference
- CVE-2018-7051: Certain nick names could result in out of bounds access
when printing theme strings


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-171=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

irssi-1.0.7-25.1
irssi-debuginfo-1.0.7-25.1
irssi-debugsource-1.0.7-25.1
irssi-devel-1.0.7-25.1


References:

https://www.suse.com/security/cve/CVE-2018-7050.html
https://www.suse.com/security/cve/CVE-2018-7051.html
https://www.suse.com/security/cve/CVE-2018-7052.html
https://www.suse.com/security/cve/CVE-2018-7053.html
https://www.suse.com/security/cve/CVE-2018-7054.html
https://bugzilla.suse.com/1081238


< Previous Next >
This Thread
  • No further messages