Mailinglist Archive: opensuse-updates (111 mails)

< Previous Next >
openSUSE-SU-2018:0418-1: moderate: Security update for libxml2
openSUSE Security Update: Security update for libxml2
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:0418-1
Rating: moderate
References: #1077993 #1078806 #1078813
Cross-References: CVE-2016-5131 CVE-2017-15412 CVE-2017-5130

Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

This update for libxml2 fixes three security issues:

- CVE-2017-15412: Prevent use after free when calling XPath extension
functions that allowed remote attackers to cause DoS or potentially RCE
(bsc#1077993)
- CVE-2016-5131: Use-after-free vulnerability in libxml2 allowed remote
attackers to cause a denial of service or possibly have unspecified
other impact via vectors related to the XPointer range-to function.
(bsc#1078813)
- CVE-2017-5130: Fixed a potential remote buffer overflow in function
xmlMemoryStrdup() (bsc#1078806)

This update was imported from the SUSE:SLE-12-SP2:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-154=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

libxml2-2-2.9.4-15.1
libxml2-2-debuginfo-2.9.4-15.1
libxml2-debugsource-2.9.4-15.1
libxml2-devel-2.9.4-15.1
libxml2-tools-2.9.4-15.1
libxml2-tools-debuginfo-2.9.4-15.1
python-libxml2-2.9.4-15.1
python-libxml2-debuginfo-2.9.4-15.1
python-libxml2-debugsource-2.9.4-15.1

- openSUSE Leap 42.3 (noarch):

libxml2-doc-2.9.4-15.1

- openSUSE Leap 42.3 (x86_64):

libxml2-2-32bit-2.9.4-15.1
libxml2-2-debuginfo-32bit-2.9.4-15.1
libxml2-devel-32bit-2.9.4-15.1


References:

https://www.suse.com/security/cve/CVE-2016-5131.html
https://www.suse.com/security/cve/CVE-2017-15412.html
https://www.suse.com/security/cve/CVE-2017-5130.html
https://bugzilla.suse.com/1077993
https://bugzilla.suse.com/1078806
https://bugzilla.suse.com/1078813


< Previous Next >
This Thread
  • No further messages