Mailinglist Archive: opensuse-updates (126 mails)

< Previous Next >
openSUSE-SU-2018:0058-1: moderate: Security update for irssi
openSUSE Security Update: Security update for irssi
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:0058-1
Rating: moderate
References: #1074958
Cross-References: CVE-2018-5205 CVE-2018-5206 CVE-2018-5207
CVE-2018-5208
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:

This update for irssi to version 1.0.6 fixes several issues that may
affect the stability of irssi:

- CVE-2018-5205: Data access beyond the end of the string when using
incomplete escape codes
- CVE-2018-5206: NULL pointer dereference when the channel topic is set
without specifying a sender
- CVE-2018-5207: When using an incomplete variable argument, Irssi may
access data beyond the end of the string
- CVE-2018-5208: Heap buffer overflow when completing certain strings


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-18=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2018-18=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

irssi-1.0.6-21.1
irssi-debuginfo-1.0.6-21.1
irssi-debugsource-1.0.6-21.1
irssi-devel-1.0.6-21.1

- openSUSE Leap 42.2 (i586 x86_64):

irssi-1.0.6-14.18.1
irssi-debuginfo-1.0.6-14.18.1
irssi-debugsource-1.0.6-14.18.1
irssi-devel-1.0.6-14.18.1


References:

https://www.suse.com/security/cve/CVE-2018-5205.html
https://www.suse.com/security/cve/CVE-2018-5206.html
https://www.suse.com/security/cve/CVE-2018-5207.html
https://www.suse.com/security/cve/CVE-2018-5208.html
https://bugzilla.suse.com/1074958


< Previous Next >
This Thread
  • No further messages