Mailinglist Archive: opensuse-updates (119 mails)

< Previous Next >
openSUSE-SU-2017:3257-1: moderate: Security update for erlang
openSUSE Security Update: Security update for erlang
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:3257-1
Rating: moderate
References: #1030062
Cross-References: CVE-2016-10253 CVE-2017-1000385
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for erlang fixes security issues and bugs.

The following vulnerabilities were addressed:

- CVE-2017-1000385: Harden against the Bleichenbacher attacher against RSA
- CVE-2016-10253: Heap overflow through regular expressions (bsc#1030062)

In addition Erlang was updated to version 18.3.4.6, containing a number
of upstream bug fixes and improvements.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-1358=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-1358=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (x86_64):

erlang-18.3.4.7-6.1
erlang-debugger-18.3.4.7-6.1
erlang-debugger-src-18.3.4.7-6.1
erlang-debuginfo-18.3.4.7-6.1
erlang-debugsource-18.3.4.7-6.1
erlang-dialyzer-18.3.4.7-6.1
erlang-dialyzer-debuginfo-18.3.4.7-6.1
erlang-dialyzer-src-18.3.4.7-6.1
erlang-diameter-18.3.4.7-6.1
erlang-diameter-src-18.3.4.7-6.1
erlang-doc-18.3.4.7-6.1
erlang-epmd-18.3.4.7-6.1
erlang-epmd-debuginfo-18.3.4.7-6.1
erlang-et-18.3.4.7-6.1
erlang-et-src-18.3.4.7-6.1
erlang-gs-18.3.4.7-6.1
erlang-gs-src-18.3.4.7-6.1
erlang-jinterface-18.3.4.7-6.1
erlang-jinterface-src-18.3.4.7-6.1
erlang-observer-18.3.4.7-6.1
erlang-observer-src-18.3.4.7-6.1
erlang-reltool-18.3.4.7-6.1
erlang-reltool-src-18.3.4.7-6.1
erlang-src-18.3.4.7-6.1
erlang-wx-18.3.4.7-6.1
erlang-wx-debuginfo-18.3.4.7-6.1
erlang-wx-src-18.3.4.7-6.1

- openSUSE Leap 42.2 (i586 x86_64):

erlang-18.3.4.7-2.7.1
erlang-debugger-18.3.4.7-2.7.1
erlang-debugger-src-18.3.4.7-2.7.1
erlang-debuginfo-18.3.4.7-2.7.1
erlang-debugsource-18.3.4.7-2.7.1
erlang-dialyzer-18.3.4.7-2.7.1
erlang-dialyzer-debuginfo-18.3.4.7-2.7.1
erlang-dialyzer-src-18.3.4.7-2.7.1
erlang-diameter-18.3.4.7-2.7.1
erlang-diameter-src-18.3.4.7-2.7.1
erlang-doc-18.3.4.7-2.7.1
erlang-epmd-18.3.4.7-2.7.1
erlang-epmd-debuginfo-18.3.4.7-2.7.1
erlang-et-18.3.4.7-2.7.1
erlang-et-src-18.3.4.7-2.7.1
erlang-gs-18.3.4.7-2.7.1
erlang-gs-src-18.3.4.7-2.7.1
erlang-jinterface-18.3.4.7-2.7.1
erlang-jinterface-src-18.3.4.7-2.7.1
erlang-observer-18.3.4.7-2.7.1
erlang-observer-src-18.3.4.7-2.7.1
erlang-reltool-18.3.4.7-2.7.1
erlang-reltool-src-18.3.4.7-2.7.1
erlang-src-18.3.4.7-2.7.1
erlang-wx-18.3.4.7-2.7.1
erlang-wx-debuginfo-18.3.4.7-2.7.1
erlang-wx-src-18.3.4.7-2.7.1


References:

https://www.suse.com/security/cve/CVE-2016-10253.html
https://www.suse.com/security/cve/CVE-2017-1000385.html
https://bugzilla.suse.com/1030062


< Previous Next >
This Thread
  • No further messages