Mailinglist Archive: opensuse-updates (119 mails)

< Previous Next >
openSUSE-SU-2017:3256-1: moderate: Security update for libXfont
openSUSE Security Update: Security update for libXfont
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:3256-1
Rating: moderate
References: #1049692 #1050459 #1054285
Cross-References: CVE-2017-13720 CVE-2017-13722
Affected Products:
openSUSE Leap 42.2
______________________________________________________________________________

An update that solves two vulnerabilities and has one
errata is now available.

Description:

This update for libXfont fixes several issues.

These security issues were fixed:

- CVE-2017-13720: Improper check for end of string in PatterMatch caused
invalid reads (bsc#1054285)
- CVE-2017-13722: Malformed PCF file could have caused DoS or leak
information (bsc#1049692)
- Prevent the X server from accessing arbitrary files as root. It is not
possible to leak information, but special files can be touched allowing
for causing side effects (bsc#1050459)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-1357=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (i586 x86_64):

libXfont-debugsource-1.5.1-9.3.1
libXfont-devel-1.5.1-9.3.1
libXfont1-1.5.1-9.3.1
libXfont1-debuginfo-1.5.1-9.3.1

- openSUSE Leap 42.2 (x86_64):

libXfont-devel-32bit-1.5.1-9.3.1
libXfont1-32bit-1.5.1-9.3.1
libXfont1-debuginfo-32bit-1.5.1-9.3.1


References:

https://www.suse.com/security/cve/CVE-2017-13720.html
https://www.suse.com/security/cve/CVE-2017-13722.html
https://bugzilla.suse.com/1049692
https://bugzilla.suse.com/1050459
https://bugzilla.suse.com/1054285


< Previous Next >
This Thread
  • No further messages