Mailinglist Archive: opensuse-updates (119 mails)

< Previous Next >
openSUSE-SU-2017:3243-1: moderate: Security update for openssh
openSUSE Security Update: Security update for openssh
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:3243-1
Rating: moderate
References: #1006166 #1048367 #1065000 #1068310 #1069509

Cross-References: CVE-2008-1483 CVE-2017-15906
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that solves two vulnerabilities and has three
fixes is now available.

Description:

This update for openssh fixes the following issues:

Security issue fixed:

- CVE-2017-15906: Stricter checking of operations in read-only mode in
sftp server (bsc#1065000).

Bug fixes:

- FIPS: Startup selfchecks (bsc#1068310).
- FIPS: Silent complaints about unsupported key exchange methods
(bsc#1006166).
- Refine handling of sockets for X11 forwarding to remove reintroduced
CVE-2008-1483 (bsc#1069509).
- Test configuration before running daemon to prevent looping resulting in
service shutdown (bsc#1048367)

This update was imported from the SUSE:SLE-12-SP2:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-1351=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-1351=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

openssh-7.2p2-15.1
openssh-askpass-gnome-7.2p2-15.1
openssh-askpass-gnome-debuginfo-7.2p2-15.1
openssh-cavs-7.2p2-15.1
openssh-cavs-debuginfo-7.2p2-15.1
openssh-debuginfo-7.2p2-15.1
openssh-debugsource-7.2p2-15.1
openssh-fips-7.2p2-15.1
openssh-helpers-7.2p2-15.1
openssh-helpers-debuginfo-7.2p2-15.1

- openSUSE Leap 42.2 (i586 x86_64):

openssh-7.2p2-11.6.1
openssh-askpass-gnome-7.2p2-11.6.1
openssh-askpass-gnome-debuginfo-7.2p2-11.6.1
openssh-cavs-7.2p2-11.6.1
openssh-cavs-debuginfo-7.2p2-11.6.1
openssh-debuginfo-7.2p2-11.6.1
openssh-debugsource-7.2p2-11.6.1
openssh-fips-7.2p2-11.6.1
openssh-helpers-7.2p2-11.6.1
openssh-helpers-debuginfo-7.2p2-11.6.1


References:

https://www.suse.com/security/cve/CVE-2008-1483.html
https://www.suse.com/security/cve/CVE-2017-15906.html
https://bugzilla.suse.com/1006166
https://bugzilla.suse.com/1048367
https://bugzilla.suse.com/1065000
https://bugzilla.suse.com/1068310
https://bugzilla.suse.com/1069509


< Previous Next >
This Thread
  • No further messages