Mailinglist Archive: opensuse-updates (123 mails)

< Previous Next >
openSUSE-RU-2017:2883-1: moderate: Recommended update for gdb
openSUSE Recommended Update: Recommended update for gdb
______________________________________________________________________________

Announcement ID: openSUSE-RU-2017:2883-1
Rating: moderate
References: #1056437 #1062315 #1062316 #1062318 #985550

Affected Products:
openSUSE Leap 42.2
______________________________________________________________________________

An update that has 5 recommended fixes can now be installed.

Description:

The GNU Debugger GDB was updated to the 8.0.1 release, bringing lots of
features and bugfixes.


- Link gdb against a bundled libipt (processor trace library) on x86_64
and i686 for improved tracing support
on Intel CPUs. [bsc#985550]

- Rebase to 8.0.1 release (fixing PR21886, PR22046)

- Updated libstdc++ pretty printers to
gdb-libstdc++-v3-python-7.1.1-20170526.tar.bz2 .

- Add support for zSeries z14 specific features [fate#321514, bsc#1062315,
fate#322272, bsc#1062318]

- Disable guile extensions for new distros, the gdb support is
incompatible with guile 2.2.

- Rebase to gdb 8.0 release: [fate#319573]

* support for DWARF5 (except its .debug_names)
* support C++11 rvalue references
* support PKU register (memory protection keys on future Intel CPUs)
* python scripting:
- start, stop and access running btrace
- rvalue references in gdb.Type
* record/replay x86_64 rdrand and rdseed
* removed support for GCJ compiled java programs
* user commands accept more than 10 arguments
* "eval" expands user-defined command arguments
* new options: set/show disassembler-options (on arm, ppc s390)

- Update to gdb 7.12.1

* negative repeat count for x examines backwards
* fortran: support structs/arrays with dynamically types fields
* support MPX bound checking
* support for the Rust language
* 'catch syscall' now can catch groups of related syscalls
* New (sub)commands:
- skip {-file,-gfile,-function,-rfunction}: generic skip mechanism
- maint {selftest,info line-table}
- new-ui: create new user interface for GUI clients
* (fast) tracepoints on s390x and ppc64le added to gdbserver
* New target Andes NDS32


This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-1212=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (i586 x86_64):

gdb-8.0.1-18.3.1
gdb-debuginfo-8.0.1-18.3.1
gdb-debugsource-8.0.1-18.3.1
gdb-testresults-8.0.1-18.3.1
gdbserver-8.0.1-18.3.1
gdbserver-debuginfo-8.0.1-18.3.1


References:

https://bugzilla.suse.com/1056437
https://bugzilla.suse.com/1062315
https://bugzilla.suse.com/1062316
https://bugzilla.suse.com/1062318
https://bugzilla.suse.com/985550


< Previous Next >
This Thread
  • No further messages