Mailinglist Archive: opensuse-updates (123 mails)

< Previous Next >
openSUSE-RU-2017:2827-1: moderate: Recommended update for yast2 and yast2-network
openSUSE Recommended Update: Recommended update for yast2 and yast2-network
______________________________________________________________________________

Announcement ID: openSUSE-RU-2017:2827-1
Rating: moderate
References: #1026027 #1036440 #1037214 #1037727 #1038717
#1050986 #932331
Affected Products:
openSUSE Leap 42.2
______________________________________________________________________________

An update that has 7 recommended fixes can now be installed.

Description:

This update for yast2 and yast2-network provides the following fixes:

- Fix udev rules export when more than one device is configured.
(bsc#1050986)
- Avoid creating duplicate udev rules in AutoYaST installation.
(bsc#1038717)
- Fix device name recognition during AutoYaST installation. (bsc#1037727)
- Change dhclient configuration warning messages to not block AutoYaST.
(bsc#1037727)
- Improve the logic to report if SuSEfirewall2 is selected or installed
when installing OES using integrated media to make sure it gets properly
activated. The problem would happen once the product is registered and
manual network configuration is selected. (bnc#1037214)
- Fix a problem that was causing warning messages to open a UI dialog in
command-line mode and wait for user input. (bsc#1036440).
- Remove the usage and the dependency on insserv as it is not really
necessary. (bsc#1026027)
- Fix some tests to work with the latest yast2-core package. (bsc#932331)
- Add a CWM::ReplacePoint widget.
- Add a generic CWM widget for keyboard layout. (FATE#321754)
- Fix error popup when replacing widget with CWM::ReplacePoint.
(FATE#322328)
- When skipping storing of widget values, skip also its validation.
(FATE#322328)

This update was imported from the SUSE:SLE-12-SP2:Update update project.


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-1184=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (i586 x86_64):

yast2-3.1.217-5.6.1
yast2-network-3.1.181-5.9.1


References:

https://bugzilla.suse.com/1026027
https://bugzilla.suse.com/1036440
https://bugzilla.suse.com/1037214
https://bugzilla.suse.com/1037727
https://bugzilla.suse.com/1038717
https://bugzilla.suse.com/1050986
https://bugzilla.suse.com/932331


< Previous Next >
This Thread
  • No further messages