Mailinglist Archive: opensuse-updates (127 mails)

< Previous Next >
openSUSE-SU-2017:2483-1: moderate: Security update for cvs
openSUSE Security Update: Security update for cvs
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:2483-1
Rating: moderate
References: #1053364
Cross-References: CVE-2017-12836
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for cvs fixes the following issues:

- CVE-2017-12836: A leading dash in the argument of the "-d" option could
lead to argument injection (bsc#1053364)

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-1060=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-1060=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

cvs-1.12.12-188.1
cvs-debuginfo-1.12.12-188.1
cvs-debugsource-1.12.12-188.1

- openSUSE Leap 42.3 (noarch):

cvs-doc-1.12.12-188.1

- openSUSE Leap 42.2 (i586 x86_64):

cvs-1.12.12-185.3.1
cvs-debuginfo-1.12.12-185.3.1
cvs-debugsource-1.12.12-185.3.1

- openSUSE Leap 42.2 (noarch):

cvs-doc-1.12.12-185.3.1


References:

https://www.suse.com/security/cve/CVE-2017-12836.html
https://bugzilla.suse.com/1053364


< Previous Next >
This Thread
  • No further messages