Mailinglist Archive: opensuse-updates (127 mails)

< Previous Next >
openSUSE-SU-2017:2364-1: moderate: Security update for icu
openSUSE Security Update: Security update for icu
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:2364-1
Rating: moderate
References: #929629
Cross-References: CVE-2014-8146 CVE-2014-8147
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

icu was updated to fix two security issues.

These security issues were fixed:
- CVE-2014-8147: The resolveImplicitLevels function in common/ubidi.c in
the Unicode Bidirectional Algorithm implementation in ICU4C in
International Components for Unicode (ICU) used an integer data type
that is inconsistent with a header file, which allowed remote attackers
to cause a denial of service (incorrect malloc followed by invalid free)
or possibly execute arbitrary code via crafted text (bsc#929629).
- CVE-2014-8146: The resolveImplicitLevels function in common/ubidi.c in
the Unicode Bidirectional Algorithm implementation in ICU4C in
International Components for Unicode (ICU) did not properly track
directionally isolated pieces of text, which allowed remote attackers to
cause a denial of service (heap-based buffer overflow) or possibly
execute arbitrary code via crafted text (bsc#929629).

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-1011=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-1011=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

icu-52.1-15.1
icu-data-52.1-15.1
icu-debuginfo-52.1-15.1
icu-debugsource-52.1-15.1
libicu-devel-52.1-15.1
libicu-doc-52.1-15.1
libicu52_1-52.1-15.1
libicu52_1-data-52.1-15.1
libicu52_1-debuginfo-52.1-15.1

- openSUSE Leap 42.3 (x86_64):

libicu-devel-32bit-52.1-15.1
libicu52_1-32bit-52.1-15.1
libicu52_1-debuginfo-32bit-52.1-15.1

- openSUSE Leap 42.2 (i586 x86_64):

icu-52.1-12.3.1
icu-data-52.1-12.3.1
icu-debuginfo-52.1-12.3.1
icu-debugsource-52.1-12.3.1
libicu-devel-52.1-12.3.1
libicu-doc-52.1-12.3.1
libicu52_1-52.1-12.3.1
libicu52_1-data-52.1-12.3.1
libicu52_1-debuginfo-52.1-12.3.1

- openSUSE Leap 42.2 (x86_64):

libicu-devel-32bit-52.1-12.3.1
libicu52_1-32bit-52.1-12.3.1
libicu52_1-debuginfo-32bit-52.1-12.3.1


References:

https://www.suse.com/security/cve/CVE-2014-8146.html
https://www.suse.com/security/cve/CVE-2014-8147.html
https://bugzilla.suse.com/929629


< Previous Next >
This Thread
  • No further messages