Mailinglist Archive: opensuse-updates (127 mails)

< Previous Next >
openSUSE-SU-2017:2336-1: moderate: Security update for expat
openSUSE Security Update: Security update for expat
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:2336-1
Rating: moderate
References: #1047236 #1047240
Cross-References: CVE-2016-9063 CVE-2017-9233
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for expat fixes the following issues:

- CVE-2016-9063: Possible integer overflow to fix inside XML_Parse leading
to unexpected behaviour (bsc#1047240)
- CVE-2017-9233: External Entity Vulnerability could lead to denial of
service (bsc#1047236)

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-993=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-993=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

expat-2.1.0-24.1
expat-debuginfo-2.1.0-24.1
expat-debugsource-2.1.0-24.1
libexpat-devel-2.1.0-24.1
libexpat1-2.1.0-24.1
libexpat1-debuginfo-2.1.0-24.1

- openSUSE Leap 42.3 (x86_64):

expat-debuginfo-32bit-2.1.0-24.1
libexpat-devel-32bit-2.1.0-24.1
libexpat1-32bit-2.1.0-24.1
libexpat1-debuginfo-32bit-2.1.0-24.1

- openSUSE Leap 42.2 (i586 x86_64):

expat-2.1.0-21.3.1
expat-debuginfo-2.1.0-21.3.1
expat-debugsource-2.1.0-21.3.1
libexpat-devel-2.1.0-21.3.1
libexpat1-2.1.0-21.3.1
libexpat1-debuginfo-2.1.0-21.3.1

- openSUSE Leap 42.2 (x86_64):

expat-debuginfo-32bit-2.1.0-21.3.1
libexpat-devel-32bit-2.1.0-21.3.1
libexpat1-32bit-2.1.0-21.3.1
libexpat1-debuginfo-32bit-2.1.0-21.3.1


References:

https://www.suse.com/security/cve/CVE-2016-9063.html
https://www.suse.com/security/cve/CVE-2017-9233.html
https://bugzilla.suse.com/1047236
https://bugzilla.suse.com/1047240


< Previous Next >
This Thread
  • No further messages