Mailinglist Archive: opensuse-updates (124 mails)

< Previous Next >
openSUSE-SU-2017:1958-1: moderate: Security update for Wireshark
openSUSE Security Update: Security update for Wireshark
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:1958-1
Rating: moderate
References: #1049255 #1049621
Cross-References: CVE-2017-11406 CVE-2017-11407 CVE-2017-11408
CVE-2017-11410 CVE-2017-11411 CVE-2017-7702
CVE-2017-9350
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes 7 vulnerabilities is now available.

Description:

This update to Wireshark 2.2.8 fixes some minor vulnerabilities could be
used to trigger dissector crashes, infinite loops, or cause excessive use
of memory resources by making Wireshark read specially crafted packages
from the network
or a capture file:

- CVE-2017-7702,CVE-2017-11410: WBMXL dissector infinite loop
(wnpa-sec-2017-13)
- CVE-2017-9350,CVE-2017-11411: openSAFETY dissector memory exhaustion
(wnpa-sec-2017-28)
- CVE-2017-11408: AMQP dissector crash (wnpa-sec-2017-34)
- CVE-2017-11407: MQ dissector crash (wnpa-sec-2017-35)
- CVE-2017-11406: DOCSIS infinite loop (wnpa-sec-2017-36)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-840=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-840=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (x86_64):

wireshark-2.2.8-17.1
wireshark-debuginfo-2.2.8-17.1
wireshark-debugsource-2.2.8-17.1
wireshark-devel-2.2.8-17.1
wireshark-ui-gtk-2.2.8-17.1
wireshark-ui-gtk-debuginfo-2.2.8-17.1
wireshark-ui-qt-2.2.8-17.1
wireshark-ui-qt-debuginfo-2.2.8-17.1

- openSUSE Leap 42.2 (x86_64):

wireshark-2.2.8-14.9.1
wireshark-debuginfo-2.2.8-14.9.1
wireshark-debugsource-2.2.8-14.9.1
wireshark-devel-2.2.8-14.9.1
wireshark-ui-gtk-2.2.8-14.9.1
wireshark-ui-gtk-debuginfo-2.2.8-14.9.1
wireshark-ui-qt-2.2.8-14.9.1
wireshark-ui-qt-debuginfo-2.2.8-14.9.1


References:

https://www.suse.com/security/cve/CVE-2017-11406.html
https://www.suse.com/security/cve/CVE-2017-11407.html
https://www.suse.com/security/cve/CVE-2017-11408.html
https://www.suse.com/security/cve/CVE-2017-11410.html
https://www.suse.com/security/cve/CVE-2017-11411.html
https://www.suse.com/security/cve/CVE-2017-7702.html
https://www.suse.com/security/cve/CVE-2017-9350.html
https://bugzilla.suse.com/1049255
https://bugzilla.suse.com/1049621


< Previous Next >
This Thread
  • No further messages