Mailinglist Archive: opensuse-updates (124 mails)

< Previous Next >
openSUSE-SU-2017:1811-1: moderate: Security update for vim
openSUSE Security Update: Security update for vim
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:1811-1
Rating: moderate
References: #1018870 #1024724 #1027053 #1027057
Cross-References: CVE-2017-5953 CVE-2017-6349 CVE-2017-6350

Affected Products:
openSUSE Leap 42.2
______________________________________________________________________________

An update that solves three vulnerabilities and has one
errata is now available.

Description:


This update for vim fixes the following issues:

Security issues fixed:

- CVE-2017-5953: Fixed a possible overflow with corrupted spell file
(bsc#1024724)
- CVE-2017-6350: Fixed a possible overflow when reading a corrupted undo
file (bsc#1027053)
- CVE-2017-6349: Fixed a possible overflow when reading a corrupted undo
file (bsc#1027057)

Non security issues fixed:

- Speed up YAML syntax highlighting (bsc#1018870)

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-788=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (i586 x86_64):

gvim-7.4.326-10.3.1
gvim-debuginfo-7.4.326-10.3.1
vim-7.4.326-10.3.1
vim-debuginfo-7.4.326-10.3.1
vim-debugsource-7.4.326-10.3.1

- openSUSE Leap 42.2 (noarch):

vim-data-7.4.326-10.3.1


References:

https://www.suse.com/security/cve/CVE-2017-5953.html
https://www.suse.com/security/cve/CVE-2017-6349.html
https://www.suse.com/security/cve/CVE-2017-6350.html
https://bugzilla.suse.com/1018870
https://bugzilla.suse.com/1024724
https://bugzilla.suse.com/1027053
https://bugzilla.suse.com/1027057


< Previous Next >
This Thread
  • No further messages