Mailinglist Archive: opensuse-updates (124 mails)

< Previous Next >
openSUSE-OU-2017:1776-1: Optional update for postgresql96
openSUSE Optional Update: Optional update for postgresql96
______________________________________________________________________________

Announcement ID: openSUSE-OU-2017:1776-1
Rating: low
References: #1038474
Affected Products:
openSUSE Leap 42.2
______________________________________________________________________________

An update that has one optional fix can now be installed.

Description:


This update delivers PostgreSQL 9.6.3 to openSUSE Leap 42.2, following the
SUSE Linux Enterprise 12 changes.

Major enhancements in PostgreSQL 9.6 include:

- Parallel execution of sequential scans, joins and aggregates
- Avoid scanning pages unnecessarily during vacuum freeze operations
- Synchronous replication now allows multiple standby servers for
increased reliability
- Full-text search can now search for phrases (multiple adjacent words)
- postgres_fdw now supports remote joins, sorts, UPDATEs, and DELETEs
- Substantial performance improvements, especially in the area of
scalability on multi-CPU-socket servers.

Version 9.6 contains a number of changes that may affect compatibility
with previous releases. Please refer to
https://www.postgresql.org/docs/9.6/static/release-9-6.html for a
comprehensive list of changes.

The existing client libraries libecpg6 and libpq5 are now taken from the
postgresql96 build instead
of the postgresql94 build.

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Optional Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-769=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (i586 x86_64):

libecpg6-9.6.3-2.1
libecpg6-debuginfo-9.6.3-2.1
libpq5-9.6.3-2.1
libpq5-debuginfo-9.6.3-2.1
postgresql96-9.6.3-2.1
postgresql96-contrib-9.6.3-2.1
postgresql96-contrib-debuginfo-9.6.3-2.1
postgresql96-debuginfo-9.6.3-2.1
postgresql96-debugsource-9.6.3-2.1
postgresql96-devel-9.6.3-2.1
postgresql96-devel-debuginfo-9.6.3-2.1
postgresql96-libs-debugsource-9.6.3-2.1
postgresql96-plperl-9.6.3-2.1
postgresql96-plperl-debuginfo-9.6.3-2.1
postgresql96-plpython-9.6.3-2.1
postgresql96-plpython-debuginfo-9.6.3-2.1
postgresql96-pltcl-9.6.3-2.1
postgresql96-pltcl-debuginfo-9.6.3-2.1
postgresql96-server-9.6.3-2.1
postgresql96-server-debuginfo-9.6.3-2.1
postgresql96-test-9.6.3-2.1

- openSUSE Leap 42.2 (x86_64):

libecpg6-32bit-9.6.3-2.1
libecpg6-debuginfo-32bit-9.6.3-2.1
libpq5-32bit-9.6.3-2.1
libpq5-debuginfo-32bit-9.6.3-2.1

- openSUSE Leap 42.2 (noarch):

postgresql-init-9.6-14.3.1
postgresql96-docs-9.6.3-2.1


References:

https://bugzilla.suse.com/1038474


< Previous Next >
This Thread
  • No further messages