Mailinglist Archive: opensuse-updates (112 mails)

< Previous Next >
openSUSE-RU-2017:1425-1: Recommended update for lua
openSUSE Recommended Update: Recommended update for lua
______________________________________________________________________________

Announcement ID: openSUSE-RU-2017:1425-1
Rating: low
References: #1010089
Affected Products:
openSUSE Leap 42.2
______________________________________________________________________________

An update that has one recommended fix can now be installed.

Description:

This update provides Lua 5.2.4, which brings fixes for the following
issues:

- Wrong overflow check in table.unpack
- Ephemeron table wrongly collecting strong keys
- Crash in chunks that are too long
- Garbage collector can trigger too many times in recursive loops
- Wrong assert when reporting concatenation errors
- Wrong error message in some short-cut expressions
- luac listings choke on long strings
- Reorder items in private Table struct, restoring ABI compatibility.

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-623=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (i586 x86_64):

liblua5_2-5.2.4-5.3.1
liblua5_2-debuginfo-5.2.4-5.3.1
lua-5.2.4-5.3.1
lua-debuginfo-5.2.4-5.3.1
lua-debugsource-5.2.4-5.3.1
lua-devel-5.2.4-5.3.1

- openSUSE Leap 42.2 (noarch):

lua-doc-5.2.4-5.3.1

- openSUSE Leap 42.2 (x86_64):

liblua5_2-32bit-5.2.4-5.3.1
liblua5_2-debuginfo-32bit-5.2.4-5.3.1


References:

https://bugzilla.suse.com/1010089


< Previous Next >
This Thread
  • No further messages