Mailinglist Archive: opensuse-updates (112 mails)

< Previous Next >
openSUSE-RU-2017:1264-1: moderate: Recommended update for multipath-tools
openSUSE Recommended Update: Recommended update for multipath-tools
______________________________________________________________________________

Announcement ID: openSUSE-RU-2017:1264-1
Rating: moderate
References: #1003972 #1005255 #1005414 #1005546 #1006118
#1006469 #1008691 #1015310 #1017009 #1019181
#1019798 #1022996 #1033541 #984669 #986734
#986838 #991432 #999522
Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that has 18 recommended fixes can now be
installed.

Description:

This update for multipath-tools provides the following fixes:

- Fix sanitize delete partitions. (bsc#1033541)
- Fix check for new path states. (bsc#1019798)
- Use existing alias from bindings file. (bsc#1005255)
- Fix memory corruption problem in multipathd. (bsc#1022996)
- Sanitize how kpartx delete partitions. (bsc#1008691)
- Issue systemd READY after initial configuration. (bsc#1006469,
bsc#1006118)
- Re-add 'Before: lvm2-activation-early.service' to multipathd.service.
(bsc#1019181)
- Fix filtering of device-mapper devices. (bsc#1017009)
- Do not load invalid maps. (bsc#1005546)
- Calculate priority even for ghost paths. (bsc#1005546)
- Skip conf==NULL check in socket listener thread. (bsc#1005414)
- Set DI_SERIAL in 'multipath -ll' output. (bsc#991432)
- Fall back to search paths by devt. (bsc#1003972)
- Add new "find_multipaths" configuration option. (bsc#999522)
- Add "need_suspend" parameter. (bsc#986838)
- Check partitions unused before removing. (bsc#986838)
- Start daemon after udev trigger. (bsc#986734)
- Fix check from udev rules. (bsc#986734)
- Remove calls to dm_udev_complete. (bsc#986838)

This update was imported from the SUSE:SLE-12-SP1:Update update project.


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2017-583=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

kpartx-0.5.0-60.1
kpartx-debuginfo-0.5.0-60.1
multipath-tools-0.5.0-60.1
multipath-tools-debuginfo-0.5.0-60.1
multipath-tools-debugsource-0.5.0-60.1
multipath-tools-devel-0.5.0-60.1


References:

https://bugzilla.suse.com/1003972
https://bugzilla.suse.com/1005255
https://bugzilla.suse.com/1005414
https://bugzilla.suse.com/1005546
https://bugzilla.suse.com/1006118
https://bugzilla.suse.com/1006469
https://bugzilla.suse.com/1008691
https://bugzilla.suse.com/1015310
https://bugzilla.suse.com/1017009
https://bugzilla.suse.com/1019181
https://bugzilla.suse.com/1019798
https://bugzilla.suse.com/1022996
https://bugzilla.suse.com/1033541
https://bugzilla.suse.com/984669
https://bugzilla.suse.com/986734
https://bugzilla.suse.com/986838
https://bugzilla.suse.com/991432
https://bugzilla.suse.com/999522


< Previous Next >
This Thread
  • No further messages