Mailinglist Archive: opensuse-updates (113 mails)

< Previous Next >
openSUSE-RU-2017:1115-1: Recommended update for ruby-common, rubygem-gem2rpm
openSUSE Recommended Update: Recommended update for ruby-common,
rubygem-gem2rpm
______________________________________________________________________________

Announcement ID: openSUSE-RU-2017:1115-1
Rating: low
References: #963710
Affected Products:
openSUSE Leap 42.2
openSUSE Leap 42.1
______________________________________________________________________________

An update that has one recommended fix can now be installed.

Description:


This update for ruby-common, rubygem-gem2rpm fixes the following issues:

ruby-common:

- Since rubygems 2.5.0 the default version in the gem bin stub changed
from '>= 0' to '>= 0.a'. This was done to allow pre-release versions.
Our patching script didn't take the '.a' into account and generated
version fields like '= 0.10.1.a' instead of the expected '= 0.10.1'.
This fix accounts for the '.a'.

Changes in rubygem-gem2rpm:

- Fix 'gem2rpm --fetch': prefer https for accessing rubygems.org.
(bsc#963710)
- Add support for Ruby 2.3.0 and 2.4.0.
- Add :post_patch hook to run commands before we rebuild the gem used by
libv8.
- Add support for rubinius 2.5 and remove support for 2.2.
- No longer require the Ruby version inside the sub-package. With
BuildRequires we already make sure that the package is only built if we
find a recent enough ABI. Then the normal $interpreter(abi) requires
generated by rpm is enough.
- Move to new packaging templates by default.

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-519=1

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2017-519=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (i586 x86_64):

ruby2.1-rubygem-gem2rpm-0.10.1-5.3.1
ruby2.1-rubygem-gem2rpm-doc-0.10.1-5.3.1

- openSUSE Leap 42.2 (noarch):

ruby-common-2.1-6.3.1

- openSUSE Leap 42.1 (i586 x86_64):

ruby2.1-rubygem-gem2rpm-0.10.1-5.1
ruby2.1-rubygem-gem2rpm-doc-0.10.1-5.1

- openSUSE Leap 42.1 (noarch):

ruby-common-2.1-8.1


References:

https://bugzilla.suse.com/963710


< Previous Next >
This Thread
  • No further messages