Mailinglist Archive: opensuse-updates (113 mails)

< Previous Next >
openSUSE-SU-2017:1107-1: moderate: Security update for libsndfile
openSUSE Security Update: Security update for libsndfile
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:1107-1
Rating: moderate
References: #1033053 #1033054 #1033914 #1033915
Cross-References: CVE-2017-7585 CVE-2017-7586 CVE-2017-7741
CVE-2017-7742
Affected Products:
openSUSE Leap 42.2
openSUSE Leap 42.1
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:


This update for libsndfile fixes the following security issues:

- CVE-2017-7586: A stack-based buffer overflow via a specially crafted
FLAC file was fixed (error in the "header_read()" function) (bsc#1033053)
- CVE-2017-7585,CVE-2017-7741, CVE-2017-7742: Several stack-based buffer
overflows via a specially crafted FLAC file (error in the
"flac_buffer_copy()" function) were fixed
(bsc#1033054,bsc#1033915,bsc#1033914).

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-514=1

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2017-514=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (i586 x86_64):

libsndfile-debugsource-1.0.25-26.3.1
libsndfile-devel-1.0.25-26.3.1
libsndfile-progs-1.0.25-26.3.1
libsndfile-progs-debuginfo-1.0.25-26.3.1
libsndfile-progs-debugsource-1.0.25-26.3.1
libsndfile1-1.0.25-26.3.1
libsndfile1-debuginfo-1.0.25-26.3.1

- openSUSE Leap 42.2 (x86_64):

libsndfile1-32bit-1.0.25-26.3.1
libsndfile1-debuginfo-32bit-1.0.25-26.3.1

- openSUSE Leap 42.1 (i586 x86_64):

libsndfile-debugsource-1.0.25-27.1
libsndfile-devel-1.0.25-27.1
libsndfile-progs-1.0.25-27.1
libsndfile-progs-debuginfo-1.0.25-27.1
libsndfile-progs-debugsource-1.0.25-27.1
libsndfile1-1.0.25-27.1
libsndfile1-debuginfo-1.0.25-27.1

- openSUSE Leap 42.1 (x86_64):

libsndfile1-32bit-1.0.25-27.1
libsndfile1-debuginfo-32bit-1.0.25-27.1


References:

https://www.suse.com/security/cve/CVE-2017-7585.html
https://www.suse.com/security/cve/CVE-2017-7586.html
https://www.suse.com/security/cve/CVE-2017-7741.html
https://www.suse.com/security/cve/CVE-2017-7742.html
https://bugzilla.suse.com/1033053
https://bugzilla.suse.com/1033054
https://bugzilla.suse.com/1033914
https://bugzilla.suse.com/1033915


< Previous Next >
This Thread
  • No further messages