Mailinglist Archive: opensuse-updates (113 mails)

< Previous Next >
openSUSE-SU-2017:1076-1: Security update for gstreamer-plugins-good
openSUSE Security Update: Security update for gstreamer-plugins-good
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:1076-1
Rating: low
References: #1024014 #1024017 #1024030 #1024034 #1024062

Cross-References: CVE-2016-10198 CVE-2016-10199 CVE-2017-5840
CVE-2017-5841 CVE-2017-5845
Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that fixes 5 vulnerabilities is now available.

Description:


This update for gstreamer-plugins-good fixes the following issues:

- A crafted aac audio file could have caused an invalid read and thus
corruption or denial of service (bsc#1024014, CVE-2016-10198)
- A crafted mp4 file could have caused an invalid read and thus corruption
or denial of service (bsc#1024017, CVE-2016-10199)
- A crafted avi file could have caused an invalid read and thus corruption
or denial of service (bsc#1024034, CVE-2017-5840)
- A crafted AVI file with metadata tag entries (ncdt) could have caused
invalid read access and thus corruption or denial of service
(bsc#1024030, CVE-2017-5841)
- A crafted avi file could have caused an invalid read access resulting in
denial of service (bsc#1024062, CVE-2017-5845)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2017-495=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

gstreamer-plugins-good-1.4.5-8.1
gstreamer-plugins-good-debuginfo-1.4.5-8.1
gstreamer-plugins-good-debugsource-1.4.5-8.1
gstreamer-plugins-good-doc-1.4.5-8.1
gstreamer-plugins-good-extra-1.4.5-8.1
gstreamer-plugins-good-extra-debuginfo-1.4.5-8.1

- openSUSE Leap 42.1 (x86_64):

gstreamer-plugins-good-32bit-1.4.5-8.1
gstreamer-plugins-good-debuginfo-32bit-1.4.5-8.1
gstreamer-plugins-good-extra-32bit-1.4.5-8.1
gstreamer-plugins-good-extra-debuginfo-32bit-1.4.5-8.1

- openSUSE Leap 42.1 (noarch):

gstreamer-plugins-good-lang-1.4.5-8.1


References:

https://www.suse.com/security/cve/CVE-2016-10198.html
https://www.suse.com/security/cve/CVE-2016-10199.html
https://www.suse.com/security/cve/CVE-2017-5840.html
https://www.suse.com/security/cve/CVE-2017-5841.html
https://www.suse.com/security/cve/CVE-2017-5845.html
https://bugzilla.suse.com/1024014
https://bugzilla.suse.com/1024017
https://bugzilla.suse.com/1024030
https://bugzilla.suse.com/1024034
https://bugzilla.suse.com/1024062


< Previous Next >
This Thread
  • No further messages