Mailinglist Archive: opensuse-updates (113 mails)

< Previous Next >
openSUSE-SU-2017:1037-1: moderate: Security update for libpng15
openSUSE Security Update: Security update for libpng15
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:1037-1
Rating: moderate
References: #1017646 #958791
Cross-References: CVE-2015-8540 CVE-2016-10087
Affected Products:
openSUSE Leap 42.2
openSUSE Leap 42.1
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for libpng15 fixes the following issues:

Security issues fixed:
- CVE-2015-8540: read underflow in libpng (bsc#958791)
- CVE-2016-10087: NULL pointer dereference in png_set_text_2()
(bsc#1017646)

This update was imported from the SUSE:SLE-12-SP1:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-477=1

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2017-477=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (i586 x86_64):

libpng15-15-1.5.22-5.3.1
libpng15-15-debuginfo-1.5.22-5.3.1
libpng15-debugsource-1.5.22-5.3.1

- openSUSE Leap 42.2 (x86_64):

libpng15-15-32bit-1.5.22-5.3.1
libpng15-15-debuginfo-32bit-1.5.22-5.3.1

- openSUSE Leap 42.1 (i586 x86_64):

libpng15-15-1.5.22-7.1
libpng15-15-debuginfo-1.5.22-7.1
libpng15-debugsource-1.5.22-7.1

- openSUSE Leap 42.1 (x86_64):

libpng15-15-32bit-1.5.22-7.1
libpng15-15-debuginfo-32bit-1.5.22-7.1


References:

https://www.suse.com/security/cve/CVE-2015-8540.html
https://www.suse.com/security/cve/CVE-2016-10087.html
https://bugzilla.suse.com/1017646
https://bugzilla.suse.com/958791


< Previous Next >
This Thread
  • No further messages