Mailinglist Archive: opensuse-updates (121 mails)

< Previous Next >
openSUSE-SU-2017:0741-1: moderate: Security update for putty
openSUSE Security Update: Security update for putty
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:0741-1
Rating: moderate
References: #1029256
Cross-References: CVE-2017-6542
Affected Products:
openSUSE Leap 42.2
openSUSE Leap 42.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update to putty 0.68 fixes the following security issue:

- CVE-2017-6542: If SSH agent forwarding is enabled, local attackers that
are also able to connect to the UNIX domain socket could have
overwritten heap data (boo#1029256)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-354=1

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2017-354=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (i586 x86_64):

putty-0.68-12.1
putty-debuginfo-0.68-12.1
putty-debugsource-0.68-12.1

- openSUSE Leap 42.1 (i586 x86_64):

putty-0.68-12.1
putty-debuginfo-0.68-12.1
putty-debugsource-0.68-12.1


References:

https://www.suse.com/security/cve/CVE-2017-6542.html
https://bugzilla.suse.com/1029256


< Previous Next >
This Thread
  • No further messages