Mailinglist Archive: opensuse-updates (121 mails)

< Previous Next >
openSUSE-SU-2017:0501-1: moderate: Security update for viewvc
openSUSE Security Update: Security update for viewvc
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:0501-1
Rating: moderate
References: #1024393
Cross-References: CVE-2017-5938
Affected Products:
openSUSE Leap 42.2
openSUSE Leap 42.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:


This update for viewvc to version 1.1.26 fixes the following issues:

- vievwc 1.1.26, including one security fix:
* CVE-2017-5938 escape nav_data name to avoid XSS attack (boo#1024393)

- vievwc 1.1.25:
* fix _rev2optrev assertion on long input
- license is BSD-2-Clause, package LICENSE text

- Update viewvc.conf for Apache 2.4 syntax.

- viewvc 1.1.24:
* fix minor bug in human_readable boolean calculation
* allow hr_funout option to apply to unidiff diffs, too
* fix infinite loop in rcsparse
* fix iso8601 timezone offset handling
* add support for renamed roots
* fix minor buglet in viewvc-install error message


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-274=1

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2017-274=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (noarch):

viewvc-1.1.26-6.1

- openSUSE Leap 42.1 (noarch):

viewvc-1.1.26-5.1


References:

https://www.suse.com/security/cve/CVE-2017-5938.html
https://bugzilla.suse.com/1024393


< Previous Next >
This Thread
  • No further messages