Mailinglist Archive: opensuse-updates (121 mails)

< Previous Next >
openSUSE-SU-2017:0482-1: Security update for guile
openSUSE Security Update: Security update for guile
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:0482-1
Rating: low
References: #1004221
Cross-References: CVE-2016-8605
Affected Products:
openSUSE Leap 42.2
openSUSE Leap 42.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for guile fixes the following issues:

- CVE-2016-8605: Fixed thread-unsafe umask modification (bsc#1004221).

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-259=1

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2017-259=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (i586 x86_64):

guile-2.0.9-8.1
guile-debuginfo-2.0.9-8.1
guile-debugsource-2.0.9-8.1
guile-devel-2.0.9-8.1
guile-modules-2_0-2.0.9-8.1
libguile-2_0-22-2.0.9-8.1
libguile-2_0-22-debuginfo-2.0.9-8.1
libguilereadline-v-18-18-2.0.9-8.1
libguilereadline-v-18-18-debuginfo-2.0.9-8.1

- openSUSE Leap 42.1 (i586 x86_64):

guile-2.0.9-7.1
guile-debuginfo-2.0.9-7.1
guile-debugsource-2.0.9-7.1
guile-devel-2.0.9-7.1
guile-modules-2_0-2.0.9-7.1
libguile-2_0-22-2.0.9-7.1
libguile-2_0-22-debuginfo-2.0.9-7.1
libguilereadline-v-18-18-2.0.9-7.1
libguilereadline-v-18-18-debuginfo-2.0.9-7.1


References:

https://www.suse.com/security/cve/CVE-2016-8605.html
https://bugzilla.suse.com/1004221


< Previous Next >
This Thread
  • No further messages