Mailinglist Archive: opensuse-updates (180 mails)

< Previous Next >
openSUSE-SU-2017:0152-1: moderate: Security update for gstreamer-plugins-bad
openSUSE Security Update: Security update for gstreamer-plugins-bad
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:0152-1
Rating: moderate
References: #1013659 #1013678 #1013680
Cross-References: CVE-2016-9809 CVE-2016-9812 CVE-2016-9813

Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:


This update for gstreamer-plugins-bad fixes the following issues:

- CVE-2016-9809: Off by one read in gst_h264_parse_set_caps()
(bsc#1013659).
- CVE-2016-9812: Out of bounds read in gst_mpegts_section_new
(bsc#1013678).
- CVE-2016-9813: mpegts parser: null pointer deref in _parse_pat
(bsc#1013680).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2017-94=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

gstreamer-plugins-bad-1.4.5-11.1
gstreamer-plugins-bad-debuginfo-1.4.5-11.1
gstreamer-plugins-bad-debugsource-1.4.5-11.1
gstreamer-plugins-bad-devel-1.4.5-11.1
gstreamer-plugins-bad-doc-1.4.5-11.1
libgstbadbase-1_0-0-1.4.5-11.1
libgstbadbase-1_0-0-debuginfo-1.4.5-11.1
libgstbadvideo-1_0-0-1.4.5-11.1
libgstbadvideo-1_0-0-debuginfo-1.4.5-11.1
libgstbasecamerabinsrc-1_0-0-1.4.5-11.1
libgstbasecamerabinsrc-1_0-0-debuginfo-1.4.5-11.1
libgstcodecparsers-1_0-0-1.4.5-11.1
libgstcodecparsers-1_0-0-debuginfo-1.4.5-11.1
libgstgl-1_0-0-1.4.5-11.1
libgstgl-1_0-0-debuginfo-1.4.5-11.1
libgstinsertbin-1_0-0-1.4.5-11.1
libgstinsertbin-1_0-0-debuginfo-1.4.5-11.1
libgstmpegts-1_0-0-1.4.5-11.1
libgstmpegts-1_0-0-debuginfo-1.4.5-11.1
libgstphotography-1_0-0-1.4.5-11.1
libgstphotography-1_0-0-debuginfo-1.4.5-11.1
libgsturidownloader-1_0-0-1.4.5-11.1
libgsturidownloader-1_0-0-debuginfo-1.4.5-11.1
libgstwayland-1_0-0-1.4.5-11.1
libgstwayland-1_0-0-debuginfo-1.4.5-11.1

- openSUSE Leap 42.1 (noarch):

gstreamer-plugins-bad-lang-1.4.5-11.1

- openSUSE Leap 42.1 (x86_64):

gstreamer-plugins-bad-32bit-1.4.5-11.1
gstreamer-plugins-bad-debuginfo-32bit-1.4.5-11.1
libgstbadbase-1_0-0-32bit-1.4.5-11.1
libgstbadbase-1_0-0-debuginfo-32bit-1.4.5-11.1
libgstbadvideo-1_0-0-32bit-1.4.5-11.1
libgstbadvideo-1_0-0-debuginfo-32bit-1.4.5-11.1
libgstbasecamerabinsrc-1_0-0-32bit-1.4.5-11.1
libgstbasecamerabinsrc-1_0-0-debuginfo-32bit-1.4.5-11.1
libgstcodecparsers-1_0-0-32bit-1.4.5-11.1
libgstcodecparsers-1_0-0-debuginfo-32bit-1.4.5-11.1
libgstgl-1_0-0-32bit-1.4.5-11.1
libgstgl-1_0-0-debuginfo-32bit-1.4.5-11.1
libgstinsertbin-1_0-0-32bit-1.4.5-11.1
libgstinsertbin-1_0-0-debuginfo-32bit-1.4.5-11.1
libgstmpegts-1_0-0-32bit-1.4.5-11.1
libgstmpegts-1_0-0-debuginfo-32bit-1.4.5-11.1
libgstphotography-1_0-0-32bit-1.4.5-11.1
libgstphotography-1_0-0-debuginfo-32bit-1.4.5-11.1
libgsturidownloader-1_0-0-32bit-1.4.5-11.1
libgsturidownloader-1_0-0-debuginfo-32bit-1.4.5-11.1
libgstwayland-1_0-0-32bit-1.4.5-11.1
libgstwayland-1_0-0-debuginfo-32bit-1.4.5-11.1


References:

https://www.suse.com/security/cve/CVE-2016-9809.html
https://www.suse.com/security/cve/CVE-2016-9812.html
https://www.suse.com/security/cve/CVE-2016-9813.html
https://bugzilla.suse.com/1013659
https://bugzilla.suse.com/1013678
https://bugzilla.suse.com/1013680


< Previous Next >
This Thread
  • No further messages