Mailinglist Archive: opensuse-updates (131 mails)

< Previous Next >
openSUSE-SU-2016:2752-1: moderate: Security update for nodejs
openSUSE Security Update: Security update for nodejs
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:2752-1
Rating: moderate
References:
Cross-References: CVE-2016-5180
Affected Products:
openSUSE Leap 42.1
openSUSE 13.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:


This update for nodejs fixes the following issues:

- New upstream LTS version 4.6.1
* c-ares:
+ CVE-2016-5180: fix for single-byte buffer overwrite
- Fix nodejs-libpath.patch so ppc doesn't fail to build


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-1277=1

- openSUSE 13.2:

zypper in -t patch openSUSE-2016-1277=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

nodejs-4.6.1-36.1
nodejs-debuginfo-4.6.1-36.1
nodejs-debugsource-4.6.1-36.1
nodejs-devel-4.6.1-36.1
npm-4.6.1-36.1

- openSUSE Leap 42.1 (noarch):

nodejs-docs-4.6.1-36.1

- openSUSE 13.2 (i586 x86_64):

nodejs-4.6.1-27.1
nodejs-debuginfo-4.6.1-27.1
nodejs-debugsource-4.6.1-27.1
nodejs-devel-4.6.1-27.1

- openSUSE 13.2 (noarch):

nodejs-doc-4.6.1-27.1


References:

https://www.suse.com/security/cve/CVE-2016-5180.html


< Previous Next >
This Thread
  • No further messages