Mailinglist Archive: opensuse-updates (118 mails)

< Previous Next >
openSUSE-SU-2016:2645-1: Security update for guile
openSUSE Security Update: Security update for guile
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:2645-1
Rating: low
References: #1004221 #1004226
Cross-References: CVE-2016-8605 CVE-2016-8606
Affected Products:
openSUSE 13.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:


This update for guile fixes the following issues:

- CVE-2016-8606: REPL server vulnerable to HTTP inter-protocol attacks
(bsc#1004226).
- CVE-2016-8605: Thread-unsafe umask modification (bsc#1004221).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2016-1235=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

guile-2.0.11-3.3.1
guile-debuginfo-2.0.11-3.3.1
guile-debugsource-2.0.11-3.3.1
guile-devel-2.0.11-3.3.1
guile-modules-2_0-2.0.11-3.3.1
libguile-2_0-22-2.0.11-3.3.1
libguile-2_0-22-debuginfo-2.0.11-3.3.1
libguilereadline-v-18-18-2.0.11-3.3.1
libguilereadline-v-18-18-debuginfo-2.0.11-3.3.1


References:

https://www.suse.com/security/cve/CVE-2016-8605.html
https://www.suse.com/security/cve/CVE-2016-8606.html
https://bugzilla.suse.com/1004221
https://bugzilla.suse.com/1004226


< Previous Next >
This Thread
  • No further messages