Mailinglist Archive: opensuse-updates (118 mails)

< Previous Next >
openSUSE-SU-2016:2524-1: moderate: Security update for irssi
openSUSE Security Update: Security update for irssi
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:2524-1
Rating: moderate
References: #1001215 #999199
Cross-References: CVE-2016-7044 CVE-2016-7045 CVE-2016-7553

Affected Products:
openSUSE Leap 42.1
openSUSE 13.2
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

The IRC client irssi was updated to 0.8.20, fixing various bugs and
security issues.

* CVE-2016-7044: The unformat_24bit_color function in the format parsing
code in Irssi, when compiled with true-color enabled, allowed remote
attackers to cause a denial of service (heap corruption and crash) via
an incomplete 24bit color code.
* CVE-2016-7045: The format_send_to_gui function in the format parsing
code in Irssi allowed remote attackers to cause a denial of service
(heap corruption and crash) via vectors involving the length of a string.

See https://irssi.org/security/irssi_sa_2016.txt for more details.

* CVE-2016-7553: A information disclosure vulnerability in irssi buf.pl

See https://irssi.org/2016/09/22/buf.pl-update/ for more information.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch 5661=1

- openSUSE 13.2:

zypper in -t patch 5661=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

irssi-0.8.20-6.1
irssi-debuginfo-0.8.20-6.1
irssi-debugsource-0.8.20-6.1
irssi-devel-0.8.20-6.1

- openSUSE 13.2 (i586 x86_64):

irssi-0.8.20-3.4.1
irssi-debuginfo-0.8.20-3.4.1
irssi-debugsource-0.8.20-3.4.1
irssi-devel-0.8.20-3.4.1


References:

https://www.suse.com/security/cve/CVE-2016-7044.html
https://www.suse.com/security/cve/CVE-2016-7045.html
https://www.suse.com/security/cve/CVE-2016-7553.html
https://bugzilla.suse.com/1001215
https://bugzilla.suse.com/999199


< Previous Next >
This Thread
  • No further messages