Mailinglist Archive: opensuse-updates (111 mails)

< Previous Next >
openSUSE-SU-2016:2277-1: moderate: Security update for wget
openSUSE Security Update: Security update for wget
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:2277-1
Rating: moderate
References: #937096 #958342 #984060
Cross-References: CVE-2015-2059 CVE-2016-4971
Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that solves two vulnerabilities and has one
errata is now available.

Description:


This update for wget fixes the following issues:

- Fix for HTTP to a FTP redirection file name confusion vulnerability
(bsc#984060, CVE-2016-4971).
- Work around a libidn vulnerability (bsc#937096, CVE-2015-2059).
- Fix for wget fails with basicauth: Failed writing HTTP request: Bad
file descriptor (bsc#958342)

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-1067=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

wget-1.14-4.1
wget-debuginfo-1.14-4.1
wget-debugsource-1.14-4.1


References:

https://www.suse.com/security/cve/CVE-2015-2059.html
https://www.suse.com/security/cve/CVE-2016-4971.html
https://bugzilla.suse.com/937096
https://bugzilla.suse.com/958342
https://bugzilla.suse.com/984060


< Previous Next >
This Thread
  • No further messages