Mailinglist Archive: opensuse-updates (111 mails)

< Previous Next >
openSUSE-SU-2016:2266-1: moderate: Security update for libsrtp
openSUSE Security Update: Security update for libsrtp
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:2266-1
Rating: moderate
References: #957376
Cross-References: CVE-2015-6360
Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:


This update for libsrtp fixes the following issues:

- Update to 1.5.4:
* Use BE byte ordering of RTCP trailer.
* Allow zero length payload on unprotect.

- Update to new upstream release 1.5.3
* Maintenance release, including fix for CVE-2015-6360 boo#957376


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-1063=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

libsrtp-debugsource-1.5.4-6.1
libsrtp-devel-1.5.4-6.1
libsrtp1-1.5.4-6.1
libsrtp1-debuginfo-1.5.4-6.1

- openSUSE Leap 42.1 (x86_64):

libsrtp1-32bit-1.5.4-6.1
libsrtp1-debuginfo-32bit-1.5.4-6.1


References:

https://www.suse.com/security/cve/CVE-2015-6360.html
https://bugzilla.suse.com/957376


< Previous Next >
This Thread
  • No further messages