Mailinglist Archive: opensuse-updates (111 mails)

< Previous Next >
openSUSE-SU-2016:2252-1: moderate: Security update for tomcat
openSUSE Security Update: Security update for tomcat
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:2252-1
Rating: moderate
References: #986359 #988489
Cross-References: CVE-2016-3092 CVE-2016-5388
Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:


This update for tomcat fixes the following issues:

- CVE-2016-3092: Usage of vulnerable FileUpload package can result in
denial of service. (bsc#986359)
- CVE-2016-5388: Setting HTTP_PROXY environment variable via Proxy header.
(bsc#988489)

This update was imported from the SUSE:SLE-12-SP1:Update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-1056=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (noarch):

tomcat-8.0.32-8.1
tomcat-admin-webapps-8.0.32-8.1
tomcat-docs-webapp-8.0.32-8.1
tomcat-el-3_0-api-8.0.32-8.1
tomcat-embed-8.0.32-8.1
tomcat-javadoc-8.0.32-8.1
tomcat-jsp-2_3-api-8.0.32-8.1
tomcat-jsvc-8.0.32-8.1
tomcat-lib-8.0.32-8.1
tomcat-servlet-3_1-api-8.0.32-8.1
tomcat-webapps-8.0.32-8.1


References:

https://www.suse.com/security/cve/CVE-2016-3092.html
https://www.suse.com/security/cve/CVE-2016-5388.html
https://bugzilla.suse.com/986359
https://bugzilla.suse.com/988489


< Previous Next >
This Thread
  • No further messages