Mailinglist Archive: opensuse-updates (111 mails)

< Previous Next >
openSUSE-RU-2016:2225-1: Recommended update for jq, jsoncpp and sysdig
openSUSE Recommended Update: Recommended update for jq, jsoncpp and sysdig
______________________________________________________________________________

Announcement ID: openSUSE-RU-2016:2225-1
Rating: low
References:
Affected Products:
SUSE Package Hub for SUSE Linux Enterprise 12
______________________________________________________________________________

An update that has 0 recommended fixes can now be installed.

Description:


This update provides version 0.11.0 of sysdig and adds jq and jsoncpp to
the SLE-12-SP1 Package Hub Project.

sysdig:

- Support for tracers. A way to add user level events to sysdig stream.
- New csysdig views: Traces List, Traces Summary, Traces Spectogram.
- New evtin.* and span.* filters startswith operand for strings, ex:
fd.name startswith /etc.
- evt.is_open_{read,write} fields, true or false if an event is an open()
in read or write.
- Improved performances of Kubernetes metadata parsing.
- Bug fixes for IPv6.
- Allow building with system JQ.

jq

A lightweight and flexible command-line JSON processor. jq is like sed for
JSON data – you can use it to slice and filter and map and transform
structured data with the same ease that sed, awk, grep and friends let you
play with text.

jsoncpp

JSON is a lightweight data-interchange format. It can represent numbers,
strings, ordered sequences of values, and collections of name/value pairs.
JsonCpp is a C++ library that allows manipulating JSON values, including
serialization and deserialization to and from strings. It can also
preserve existing comment in unserialization/serialization steps, making
it a convenient format to store user input files.


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Package Hub for SUSE Linux Enterprise 12:

zypper in -t patch openSUSE-2016-913=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Package Hub for SUSE Linux Enterprise 12 (aarch64 ppc64le s390x
x86_64):

jq-1.5-2.1
jsoncpp-debugsource-1.7.4-2.1
jsoncpp-devel-1.7.4-2.1
libjq-devel-1.5-2.1
libjq1-1.5-2.1
libjsoncpp1-1.7.4-2.1
libjsoncpp1-debuginfo-1.7.4-2.1

- SUSE Package Hub for SUSE Linux Enterprise 12 (x86_64):

sysdig-0.11.0-5.1
sysdig-debuginfo-0.11.0-5.1
sysdig-debugsource-0.11.0-5.1
sysdig-kmp-default-0.11.0_k3.12.49_11-5.1
sysdig-kmp-default-debuginfo-0.11.0_k3.12.49_11-5.1
sysdig-kmp-xen-0.11.0_k3.12.49_11-5.1
sysdig-kmp-xen-debuginfo-0.11.0_k3.12.49_11-5.1


References:



< Previous Next >
This Thread
  • No further messages