Mailinglist Archive: opensuse-updates (127 mails)

< Previous Next >
openSUSE-SU-2016:2204-1: moderate: Security update for cracklib
openSUSE Security Update: Security update for cracklib
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:2204-1
Rating: moderate
References: #992966
Cross-References: CVE-2016-6318
Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:


This update for cracklib fixes the following issues:

- Add patch to fix a buffer overflow in GECOS parser (bsc#992966
CVE-2016-6318)


This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-1041=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

cracklib-2.9.0-7.1
cracklib-debuginfo-2.9.0-7.1
cracklib-debugsource-2.9.0-7.1
cracklib-devel-2.9.0-7.1
cracklib-dict-small-2.9.0-7.1
libcrack2-2.9.0-7.1
libcrack2-debuginfo-2.9.0-7.1
libpwquality-debugsource-1.2.3-5.1
libpwquality-devel-1.2.3-5.1
libpwquality-tools-1.2.3-5.1
libpwquality-tools-debuginfo-1.2.3-5.1
libpwquality1-1.2.3-5.1
libpwquality1-debuginfo-1.2.3-5.1
pam_pwquality-1.2.3-5.1
pam_pwquality-debuginfo-1.2.3-5.1
python-pwquality-1.2.3-5.1
python-pwquality-debuginfo-1.2.3-5.1

- openSUSE Leap 42.1 (x86_64):

cracklib-devel-32bit-2.9.0-7.1
libcrack2-32bit-2.9.0-7.1
libcrack2-debuginfo-32bit-2.9.0-7.1

- openSUSE Leap 42.1 (noarch):

libpwquality-lang-1.2.3-5.1


References:

https://www.suse.com/security/cve/CVE-2016-6318.html
https://bugzilla.suse.com/992966


< Previous Next >
This Thread
  • No further messages