Mailinglist Archive: opensuse-updates (127 mails)

< Previous Next >
openSUSE-SU-2016:2148-1: moderate: Security update for ImageMagick
openSUSE Security Update: Security update for ImageMagick
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:2148-1
Rating: moderate
References: #991444 #991445 #991872
Cross-References: CVE-2016-5010 CVE-2016-6491 CVE-2016-6520

Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:


This update for ImageMagick fixes the following issues:

- security update:
* CVE-2016-6520: buffer overflow [bsc#991872]
* CVE-2016-5010: Out-of-bounds read in CopyMagickMemory [bsc#991444]
* CVE-2016-6491: Out-of-bounds read when processing crafted tiff files
[bsc#991445]

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-1016=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

ImageMagick-6.8.8.1-18.2
ImageMagick-debuginfo-6.8.8.1-18.2
ImageMagick-debugsource-6.8.8.1-18.2
ImageMagick-devel-6.8.8.1-18.2
ImageMagick-extra-6.8.8.1-18.2
ImageMagick-extra-debuginfo-6.8.8.1-18.2
libMagick++-6_Q16-3-6.8.8.1-18.2
libMagick++-6_Q16-3-debuginfo-6.8.8.1-18.2
libMagick++-devel-6.8.8.1-18.2
libMagickCore-6_Q16-1-6.8.8.1-18.2
libMagickCore-6_Q16-1-debuginfo-6.8.8.1-18.2
libMagickWand-6_Q16-1-6.8.8.1-18.2
libMagickWand-6_Q16-1-debuginfo-6.8.8.1-18.2
perl-PerlMagick-6.8.8.1-18.2
perl-PerlMagick-debuginfo-6.8.8.1-18.2

- openSUSE Leap 42.1 (x86_64):

ImageMagick-devel-32bit-6.8.8.1-18.2
libMagick++-6_Q16-3-32bit-6.8.8.1-18.2
libMagick++-6_Q16-3-debuginfo-32bit-6.8.8.1-18.2
libMagick++-devel-32bit-6.8.8.1-18.2
libMagickCore-6_Q16-1-32bit-6.8.8.1-18.2
libMagickCore-6_Q16-1-debuginfo-32bit-6.8.8.1-18.2
libMagickWand-6_Q16-1-32bit-6.8.8.1-18.2
libMagickWand-6_Q16-1-debuginfo-32bit-6.8.8.1-18.2

- openSUSE Leap 42.1 (noarch):

ImageMagick-doc-6.8.8.1-18.2


References:

https://www.suse.com/security/cve/CVE-2016-5010.html
https://www.suse.com/security/cve/CVE-2016-6491.html
https://www.suse.com/security/cve/CVE-2016-6520.html
https://bugzilla.suse.com/991444
https://bugzilla.suse.com/991445
https://bugzilla.suse.com/991872


< Previous Next >
This Thread
  • No further messages